Results 1 to 6 of 6

Thread: WinXP boots, but has error (Vista/XP/Mac OSX)

  1. #1
    Join Date
    Aug 2007
    Posts
    3

    Default WinXP boots, but has error (Vista/XP/Mac OSX)

    Hello there,

    First I have to thank you for having such a great tool, it made my life much easier.

    Recently I'm into installing different OS on my HDD.

    I setup Vista first, then I installed XP to run VMWARE to install Mac OS natively using VMWARE (only way i can get Mac on my drive).

    Before I install XP, i used partition manager to hide my Vista partition, so that XP will recognized its own partition as C:\ instead of some other drive letter.

    After isntalling XP, i recovered Vista's manager and used easyBCD to add XP's entry. Everything works fine at this poing, both XP and Vista boots without any problem.

    Then I got OSX on my drive, but it won't boot after i set it up in EasyBCD 1.61beta. Then I figure out it was because I set WinXP partition as active, and EasyBCD copies the nst_mac.mbr to the follow location
    C:\device\harddiskVolume2\
    where C: drive is the Vista root drive.

    Since I set XP as the active partition, it copies all boot files to XP partition, including vista's boot manager and XP's boot loader.

    But at this point my OSX won't boot. So I changed Vista's root drive to active.
    On C: there was already a boot manager installed, so I have two similar boot config on two of my primary partitions. Since now Vista is the active partition, easyBCD copies the nst_mac.mbr file correctly to C:\NST folder. After that, Mac OSX loads fine except it doesn't work on my machine because it doesn't support my SATA controller...but that's another story.

    The problem is, when Mac OSX started working, XP won't boot correctly any more. The entries in EASYBCD is fine, and it loads XP too, the only problem is that when it loads halfway, and error message pops and restarts immediately:
    Code:
    autochk program not found -skipping AUTOCHECK
    From this message, it seems that changing the active partition on my drive confuses XP about the drive path of certain programs....

    Now I can reinstall XP with no problem, but I just want to figure out whether this problem is actually related to BCD's way of applying files to partition. As i mentioned before, BCD copies file by the default active drive, but when the active drive is not Vista's drive, it causes an error when it is applying the files. This error is fine with Win XP and Vista's boot files but not Mac's and I think it might also affect linux booting.

    Please let me know if my guess is correct and help me to load XP again.


    here's my BCD config
    Code:
    There are a total of 3 entries listed in the Vista Bootloader.
    Bootloader TimeOut: 8 seconds.
    Default OS: Windows Vista (TM) Ultimate (recovered) 
    
    Entry #1
    
    Name:  Windows Vista (TM) Ultimate (recovered) 
    BCD ID:  {current}
    Drive:  C:\
    Bootloader Path:  \Windows\system32\winload.exe
    Windows Directory:  \Windows
    
    Entry #2
    
    Name:  Microsoft Windows XP Pro
    BCD ID:  {7fa4761c-4e83-11dc-a3b1-ff20c620d3eb}
    Drive: Active Boot Partition
    Bootloader Path:  \NTLDR
    
    Entry #3
    
    Name:  Mac OS X
    BCD ID:  {7fa4761d-4e83-11dc-a3b1-ff20c620d3eb}
    Drive: Active Boot Partition
    Bootloader Path:  \NST\nst_mac.mbr
    And also my partition table is config like this
    Code:
    1st partition --- Vista partition (Primary, NTFS, Active)
    2nd partition --- XP partition (Primary, NTFS)
    3rd partition --- Mac OSX (Primary, HFS+)
    fourth --- Extended Partition
    4th ---   linux swap
    5th ---    linux Ext3
    6th ---   NTFS logical
    7th ---   FAT32 logical

  2. #2
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,322

     

    Hi alloy, welcome to NeoSmart Technologies.

    Sounds like an XP boot.ini misconfiguration error. Check your boot.ini (on both the XP and Vista drives, please), and see if you can spot a glitch in the numbering (it *should* change when you set the XP partition to bootable or otherwise). If it's all correct, then probably at some point your XP install was corrupted and you'll have to do a repair install to get it to work.

    If you do go down the repair install path, be sure to perform the repair install with the Vista partition set as active to avoid any further complications.
    Once XP is installed, run EasyBCD from there | Bootloader Management | Reinstall Vista bootloader to get everything working again.

    Cheers!
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  3. #3
    Join Date
    Aug 2007
    Posts
    3

     

    Hi again, thanks for the reply.

    I checked boot.ini in both XP and Vista partition, both of them looked the same:
    Code:
    [boot loader]
    timeout=30
    default=multi(0)disk(0)rdisk(0)partition(2)\WINDOWS
    [operating systems]
    multi(0)disk(0)rdisk(0)partition(2)\WINDOWS="Microsoft Windows XP Professional" /noexecute=optin /fastdetect
    Now I want to try to repair install XP again, but there's one problem, if I set Vista as the active partition, after the repair installation, under XP the primary partition where XP is installed won't be labeled as C: drive, instead it'll be some other letter thanks to XP's partition ordering mechanism.

    For some reason, I have to keep C: drive as XP's primary drive, is there any way I can make it happen?

    I've tried partition softwares to change the order under xp but they didn't work, and I've also tried changing registry entries and that didn't work either, the only way i can do that was when I hide vista's partition and install XP on it, but by doing that, when I unhide Vista and make it primary...XP will have boot error again...

    Please let me know if there's a way to do that. thanks again.

  4. #4
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,322

     

    Don't repair install - just rebuild boot.ini from the recovery console by following the steps here: http://neosmart.net/wiki/display/EBCD/Windows+XP
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  5. #5
    Join Date
    Aug 2007
    Posts
    3

     

    Thank you very much...I fixed it....The problem was that somehow my partitioner made my XP partition hidden automatically when I set vista as active.

  6. #6
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,322

     

    Glad to hear it.

    It might be useful to do the opposite: hide the Vista partition when you boot into XP.

    This will overcome a bug where Windows XP deletes Windows Vista's restore points every time you dual-boot.
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

Similar Threads

  1. Booting Error on WinXP
    By starsnip in forum Windows Support
    Replies: 9
    Last Post: January 24th, 2009, 05:51 PM
  2. Replies: 14
    Last Post: November 18th, 2008, 09:23 AM
  3. Multiboot with 2 HD ubuntu/ winXP/ Vista
    By squir in forum EasyBCD Support
    Replies: 3
    Last Post: August 5th, 2008, 12:06 AM
  4. formating vista on laptop and installing winxp, 2k
    By vishal_y_sg in forum Hardware and Stuff
    Replies: 9
    Last Post: April 22nd, 2008, 04:44 PM
  5. Vista boots but XP only boots if Vista DVD in drive
    By JimmyG in forum EasyBCD Support
    Replies: 3
    Last Post: June 16th, 2007, 10:49 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •