Results 1 to 7 of 7

Thread: Invalid boot.ini

  1. #1
    Join Date
    Mar 2012
    Posts
    4

    Default Invalid boot.ini

    I am dual booting Windows XP and Debian Linux.

    I use Lilo to boot Linux, which is chainloaded from NTldr. That was the old system which I set up myself and it worked fine.

    Today I read that it was possible to use EasyBCD to boot XP (and also Linux) so I decided to give it a try, especially since I'd had success with EasyBCD on Vista and W7 machines (also dual booting Debian).

    I went to a W7 machine, copied the Windows\Boot folder to a USB stick, then copied that folder to C:\Windows on XP. I then installed EasyBCD, pointed it to C:\Windows\Boot to create a fake W7 entry, deleted that, and then added my XP and Debian entries. This was pretty much according to instructions online, though they did seem to relate to an older version of EasyBCD. Anyway, all seemed to go fine as far as I could tell.

    Until I rebooted that is. I got Invalid boot.ini file. XP still booted, but no way to boot Debian.

    I've done everything I know about in Windows. I've gone to XP Recovery Console and done chkdsk /r, fixboot, fixmbr, and bootcfg /rebuild. All to no avail.

    I've uninstalled EasyBCD but I still get the invalid boot.ini message. I've deleted the C:\NST folder and the C:\Windows\Boot folder (the one I copied over from W7).

    Any ideas what I can try next? I'm out of ideas!

  2. #2
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,347

     

    You can't do that with EasyBCD 2.x
    You can't just "point" EasyBCD to C:\Windows\boot\, it doesn't work like that. Installing the BCD bootloader on XP is no longer supported, you'd have to use an older version of EasyBCD. The instructions will work with v1.7.2
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  3. #3
    Join Date
    Mar 2012
    Posts
    4

     

    Thank you - yes it does work with 1.7.2. I can boot into both systems now, although I still get the invalid boot.ini message when booting into Windows, but I guess I can live with that.

    This is where I got the original instructions:
    How to: Install the Vista Bootloader on Windows XP | The NeoSmart Files

    I must admit I hadn't noticed it was from 2007, but it gives the impression this will work using the latest EasyBCD version - which we now know it doesn't.

    I don't know if out-of-date entries such as this can be changed, or taken offline, but it might save others making what became a very time-consuming mistake for me.

    Thanks again for your help.

  4. #4
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,347

     

    I can't change it because it's not supported in the latest 2.x, period. And taking it down means you can't do what you just did.

    To fix the boot.ini problem now install 2.1.2, delete the XP entry, and re-add it.
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  5. #5
    Join Date
    Mar 2012
    Posts
    4

     

    I don't understand. I thought you said I can only use 1.7.2 for this.

  6. #6
    Join Date
    Apr 2006
    Location
    Chicago
    Posts
    13,347

     

    You can only use 1.7.2 to *install* the BCD on XP. Afterwards, always use the latest EasyBCD.
    Mahmoud Al-Qudsi, Director



    I'm sorry but I do not accept support requests via IM, email, or personal messages

    Follow us on twitter @neosmart or on Facebook!
    Like us on facebook!

  7. #7
    Join Date
    Mar 2012
    Posts
    4

     

    Ok got you, and it's working perfectly now - thank you!

Similar Threads

  1. Invalid boot.ini
    By Jack_L in forum EasyBCD Support
    Replies: 1
    Last Post: July 24th, 2010, 03:51 PM
  2. Invalid Boot.Ini
    By drarche in forum EasyBCD Support
    Replies: 14
    Last Post: March 7th, 2010, 08:15 PM
  3. invalid boot.ini
    By hoon in forum EasyBCD Support
    Replies: 16
    Last Post: January 17th, 2009, 08:26 AM
  4. Invalid BOOT.INI
    By Daff in forum EasyBCD Support
    Replies: 5
    Last Post: October 14th, 2008, 07:00 PM
  5. Invalid Boot.ini
    By yoapples12310 in forum Windows Support
    Replies: 16
    Last Post: July 16th, 2008, 12:22 PM

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •