Auto Update settings not honored, and can cause crash...

#1
In trying the 2.3 beta build 205, even though I had disabled the auto update check - the app is still checking based on the following message that appears in the status bar of the UI:

EasyBCD update check failed: The remote name could not be resolved: 'api.neosmart.net'

I get this after first launching the app with my network connection disabled. But why should it even be trying when I have the 'AutoUpdate' option disabled?

With the network connection enabled - sure enough, I get the popup dialog that your newer stable build 207 has been released - with the prompt to go to the download page, etc. But again, AutoUpdate is disabled......?

I haven't actually tried the stable 207 release yet... but scanned the change log before posting this and didn't see any mention of this issue having been known/resolved.

As an aside, several times - when clicking on the 'No' button to NOT go to the download page - the tool crashed on me. That behavior is inconsistent though.
 
#2
Looks like the GA build 207 fixes it... at least, I'm not seeing the message about the update check failing when my network conn is disabled.

Cheers, and congrats on the new release!
 

mqudsi

Mostly Harmless
Staff member
#3
There weren't any changes to the autoupdate code in between those builds, I'll have to look into it.
 
#4
Please know that since I have been trying to use EasyBCD in a portable fashion - before I post problems I find, I fall back to a completely normal install. No alternate install folders, no messing with language folders, no lower-case renaming of anything - etc. So as to make sure I'm not reporting something to you that is a side effect of me messing around with the intended use of the tool.

Here's what I did:

- Disable network connection
- Choose all installation defaults for EasyBCD Beta Build 205
- Run EasyBCD at end of install
- See message that EasyBCD tried and failed to check for updates (makes sense, new install haven't disabled auto update yet)
- Go into Tools / Options and uncheck the 'AutoUpdate every' box and click Ok
- Close EasyBCD after seeing that Options were saved successffully
- Relaunch EasyBCD, see the same message that auto update check failed
- Double-check Tools / Options to make sure the setting to disable auto update was in fact properly saved, it was
- Close EasyBCD
- Enable network connection
- Relaunch EasyBCD, and quickly get a notification that a newer version of EasyBCD is available
- Triple-check Tools / Options and see that auto update is still properly DISABLED

...so something wrong here in build 205 for sure.

Repeat exact same steps after uninstalling build 205, and deleting the user settings folder under appdata\local\neosmart_technologies


- Disable network connection
- Choose all installation defaults for EasyBCD Release Build 207
- Run EasyBCD at end of install
- See message that EasyBCD tried and failed to check for updates (makes sense, new install haven't disabled auto update yet)
- Go into Tools / Options and uncheck the 'AutoUpdate every' box and click Ok
- Close EasyBCD after seeing that Options were saved successffully
- Relaunch EasyBCD, don't see any message that the tool attempted to check for updates
- Double-check Tools / Options to make sure the setting to disable auto update was in fact properly saved, it was
- Close EasyBCD
- Enable network connection
- Relaunch EasyBCD, again - don't see any message that the tool attempted to check for updates
- Triple-check Tools / Options and see that auto update is still properly DISABLED
- I ENABLE auto update check and click Ok
- Close EasyBCD after seeing that Options were saved successffully
- Relaunch EasyBCD, see the expected message that I am already runnign the latest version

...so build 207 behaving as one would expect.
 
#5
Also, these version tests were done back to back, not hours or days between - immediately before I posted the results above. So literally nothing else changed between version tests.