cannot set Legacy boot menu

#1
Hello Everyone,

I have Windows XP Pro (32 bit), 7 Pro (64 bit) and 10 Pro (64 bit) installed on the SDD. And I want to have bootloader to work in Legacy mode with Windows 10 as default system.

So I set the bootmenupolicy of the {current} entry (which is Windows 10) as "Legacy".

The problem is that every time I boot to Windows 10, shutdown and turn on the computer again, the bootloader runs in Metro mode... I have changed the displaybootmenu to "No", but there is no possitive effect...

What is the reason of this behavior and what to do, to fix this?

There is my print of bcdedit /enum command:

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=\Device\HarddiskVolume1
description Windows Boot Manager
locale en-US
inherit {globalsettings}
default {current}
resumeobject {acfc7de5-031c-11e6-85e5-d4bed97b16e2}
displayorder {ntldr}
{a8a9e16a-fa19-11e5-b1b7-abcb5c53957d}
{current}
toolsdisplayorder {memdiag}
timeout 5
displaybootmenu No

Windows Legacy OS Loader
------------------------
identifier {ntldr}
device partition=\Device\HarddiskVolume1
path \ntldr
description Microsoft Windows XP Professional
custom:250000c2 0

Windows Boot Loader
-------------------
identifier {a8a9e16a-fa19-11e5-b1b7-abcb5c53957d}
device partition=\Device\HarddiskVolume2
path \Windows\system32\winload.exe
description Microsoft Windows 7 Professional (64 bit)
locale en-US
inherit {bootloadersettings}
recoverysequence {a8a9e16b-fa19-11e5-b1b7-abcb5c53957d}
recoveryenabled Yes
osdevice partition=\Device\HarddiskVolume2
systemroot \Windows
resumeobject {a8a9e169-fa19-11e5-b1b7-abcb5c53957d}
nx OptIn
bootmenupolicy Legacy
quietboot Yes

Windows Boot Loader
-------------------
identifier {current}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows 10 Professional (64 bit)
locale en-us
inherit {bootloadersettings}
allowedinmemorysettings 0x15000075
osdevice partition=C:
systemroot \Windows
resumeobject {acfc7de5-031c-11e6-85e5-d4bed97b16e2}
nx OptIn
bootmenupolicy Legacy
 

Terry60

Knows where his towel is.
Staff member
#2
#3
Yes, after a few tests (restarts, shutdown and turn on) I think the reason was a secret hibernation... The computer is again a little bit more mine :wink:.

Thank you, Terry!

And making a secret of this shutdown/hibernation is absolutely ridiculous...

Drugi
 

Terry60

Knows where his towel is.
Staff member
#4
It's all marketing hype.
"look how much faster we've made the boot ! - switch to W10 now and see for yourself"
Not a particular problem on a W10-only PC, but a complete pita when dual-booting.
 

Drugi

New Member
#5
Yes, I understand marketing point... But slogan "We have superfast boot (which use our super algorithm which is some kind of hibernation)" is unacceptable?
Maybe... Ok, most importantly is that my problem is solved...

Best regards,
Drugi