DEP Disabling doesn't work on windows 7??

Discussion in 'Windows Support' started by kiradavey, Apr 29, 2012.

  1. kiradavey

    kiradavey New Member

    Joined:
    Apr 29, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Hi, so basically, I decided to disable my DEP (Data Execution Prevention) on my windows 7 OS yesterday. And while by no means am I a computer expert or anything of the sort, I knew what I was doing and I had opened up the CMD.exe on elevated privileges. When I typed in the command (bcdedit.exe /set {current} nx AlwaysOff) it had said that "An error occured while attemptin to reference the specified entry. The system cannot find the file specified." Also, I have tried the method for setting DEP for specific programs, which works for every program except the one that I'm trying to turn it off for. So the only option I have at this point is to disable the DEP overall. Does anyone know why the command doesnt work for me? D:
     

    Attached Files:

  2. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,596
    Likes Received:
    2
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Have you tried
    bcdedit /set nx AlwaysOff ?
    ("current" defaults)
     
  3. kiradavey

    kiradavey New Member

    Joined:
    Apr 29, 2012
    Messages:
    2
    Likes Received:
    0
    Trophy Points:
    0
    Yeah, It shows the same error. Is there any other method to turning DEP off??
     
  4. mqudsi

    mqudsi Mostly Harmless Staff Member

    Joined:
    Apr 5, 2006
    Messages:
    13,697
    Likes Received:
    5
    Trophy Points:
    38
    Location:
    Chicago

Share This Page