Dual boot W10 & LM18, W10 overwrites EasyBCD edits

#1
I decided it would be fun to dual boot Windows 10 and Linux Mint 18, but I don't like the look of the Grub bootloader, so thought I'd use EasyBCD to edit my W10 bootloader to include LM18. I have one SSD and two HDDs in my system. Windows 10 is installed on the SSD and I installed LM18 on some free space on a HDD. I made sure that the LM18 bootloader was installed on the HDD and not on the SSD. After installing LM18 I rebooted the PC, and, as expected, it boots to W10. I installed EasyBCD and followed this tutorial (below) to add a Linux OS to the Windows Bootloader.

How to add an entry for a Linux distribution in Windows’ boot menu | LinuxBSDos.com

As expected, at the first boot of W10 I was offered the option to boot into LM18, which I did. I got some LM18 updates and rebooted back into LM18. I then shut the system down and booted into W10. I then shut W10 down and restarted expecting to have the option to boot to LM18, but, to my astonishment, W10 had reverted the boot loader back to its former state. It seemed to have overwritten the EasyBCD edits. I opened up EasyBCD and could see my earlier edits to the the bootloader were still there (according to EasyBCD), but clearly, these were having no effect as the Windows bootloader was now booting straight to W10 with no other option being presented. Have I missed something?
 

Terry60

Knows where his towel is.
Staff member
#2