Help Edit Boot WIN7/XP

#21
Ok, let's cut to the chase here, and perform the following:


  1. Open "Computer" in Win 7.
  2. Double-click the C: partition to open it, and browse its files.
  3. Open "Control Panel".
  4. Go to the Folder Options.
  5. Click the View tab.
  6. Click the "Show hidden files and folders option".
  7. Uncheck the "Hide protected system files and folders" option.
  8. Uncheck the "hide file extensions" or some such option.
  9. Go back to the explorer window.
  10. Look in the root of the C: partition.
  11. You should see 3 hidden files, with the names "boot.ini, NTLDR, and NTDETECT.COM".
  12. Double-click the boot.ini file to open it in Notepad.
  13. Use Ctrl + A to select all of the contents.
  14. Use Ctrl +C to copy it.
  15. Use Ctrl + V to paste it into your next post.

Let us know how it goes. :smile:

Addendum:

If the above boot.ini you posted is actually the one on the C: partition, it looks like Easy failed to auto-configure it for some reason....hence why you can't boot into XP.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#22
Can you please do

EasyBCD | Useful Utilities | Power Console

bootgrabber.exe /list

and copy & paste the output here in a reply?


That'll help me debug what went wrong with the auto-config.

Thanks~!!
 
#23
Ok, let's cut to the chase here, and perform the following:


  1. Open "Computer" in Win 7.
  2. Double-click the C: partition to open it, and browse its files.
  3. Open "Control Panel".
  4. Go to the Folder Options.
  5. Click the View tab.
  6. Click the "Show hidden files and folders option".
  7. Uncheck the "Hide protected system files and folders" option.
  8. Uncheck the "hide file extensions" or some such option.
  9. Go back to the explorer window.
  10. Look in the root of the C: partition.
  11. You should see 3 hidden files, with the names "boot.ini, NTLDR, and NTDETECT.COM".
  12. Double-click the boot.ini file to open it in Notepad.
  13. Use Ctrl + A to select all of the contents.
  14. Use Ctrl +C to copy it.
  15. Use Ctrl + V to paste it into your next post.
Let us know how it goes. :smile:


Addendum:


If the above boot.ini you posted is actually the one on the C: partition, it looks like Easy failed to auto-configure it for some reason....hence why you can't boot into XP.

WOW... That is a mess. Please see attachment. You did want me to copy and paste all three, right? That's the way I read it.
 

Attachments

#24
Can you please do

EasyBCD | Useful Utilities | Power Console

bootgrabber.exe /list

and copy & paste the output here in a reply?


That'll help me debug what went wrong with the auto-config.

Thanks~!!

Here you go! See below:

C:\Program Files\NeoSmart Technologies\EasyBCD\bin>bootgrabber.exe /list
BootGrabber utility.
Copyright NeoSmart Technologies 2009 <http://neosmart.net/>
Error issuing IOCTL_DISK_GET_PARTITION_INFO on partition \Device\Harddisk2\Parti
tion1
D,0,500107862016
P,1,C:\,7,105908673024,50035097600,Yes
P,2,G:\,7,53409218560,53313474560,Yes
P,3,H:\,7,131072000000,130973884416,Yes
P,0,,15,209716248576,0,Yes
P,4,I:\,7,209715200000,209612574720,No
D,1,60022480896
P,1,C:\,7,60019835904,11334115328,Yes
D,2,320072933376
P,1,,66,320070288384,0,Yes
C:\Program Files\NeoSmart Technologies\EasyBCD\bin>
 
#25
WOW... That is a mess. Please see attachment. You did want me to copy and paste all three, right? That's the way I read it.
Not exactly. I wanted you only to copy the contents of boot.ini into your next post. :smile:

EDIT: But nevermind. I got the gist of it from the attached .txt file.
It is indeed the same as you posted earlier (I just wanted to make sure you grabbed the right boot.ini the first time).

So EasyBCD is indeed failing to autoconfigure it, for some reason...
Perhaps the bootgrabber output will shed light on the situation.

The line "Error issuing IOCTL_DISK_GET_PARTITION_INFO on partition \Device\Harddisk2\Parti
tion1" does indeed look interesting. Most likely something is wrong with one of the partitions on your storage HDD, and for some reason, that's interfering with BootGrabber auto-configuring boot.ini. But we'll need CG's input on this.

In the meantime, just change your boot.ini to the following:
[boot loader]
timeout=2
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NoExecute=OptIn /fastdetect
Try that, and if it doesn't boot, keep adjusting the rdisk and partition values in both lines (they will need to match), until you find the right combination (I'll go look at your screenshot of Disk Management again, I forgot what your setup looks like...).

Addendum:

Ok, it should be rdisk(2) and partition(1) in both lines of the boot.ini file.
Try that first, and if it doesn't work, change the rdisk value to a 1 instead (sometimes Disk Management sees things differently than the BIOS).
 
Last edited:
#26
Not exactly. I wanted you only to copy the contents of boot.ini into your next post. :smile:

EDIT: But nevermind. I got the gist of it from the attached .txt file.
It is indeed the same as you posted earlier (I just wanted to make sure you grabbed the right boot.ini the first time).

So EasyBCD is indeed failing to autoconfigure it, for some reason...
Perhaps the bootgrabber output will shed light on the situation.

The line "Error issuing IOCTL_DISK_GET_PARTITION_INFO on partition \Device\Harddisk2\Parti
tion1" does indeed look interesting. Most likely something is wrong with one of the partitions on your storage HDD, and for some reason, that's interfering with BootGrabber auto-configuring boot.ini. But we'll need CG's input on this.

In the meantime, just change your boot.ini to the following:
Try that, and if it doesn't boot, keep adjusting the rdisk and partition values in both lines (they will need to match), until you find the right combination (I'll go look at your screenshot of Disk Management again, I forgot what your setup looks like...).


Addendum:


Ok, it should be rdisk(2) and partition(1) in both lines of the boot.ini file.
Try that first, and if it doesn't work, change the rdisk value to a 1 instead (sometimes Disk Management sees things differently than the BIOS).
So I tried your addendum rdisk(2), no luck. Restarted same error. Then went as far as to start EasyBCD, deleted XP, re-added XP, restarted and again same error.

Help me! I really want to keep xp working. Dual boot seems like the best way to go. I have Adobe CS3 running on my XP and I desperately need to get it working again.
 
#27
Please verify that your XP entry in the BCD is pointing at the "system" partition, not the XP partition, and that you also tried rdisk(1) as well in the boot.ini.
 
#28
First and foremost, I owe you a huge thanks. Got it working!

I had to shutdown and take a break today. The settings that finally worked are below:
;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=2
default=multi(0)disk(0)rdisk(1)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(1)partition(1)\WINDOWS="Microsoft Windows XP Professional" /NoExecute=OptIn /fastdetect

rdisk(2) ended up giving me the following error:
windows could not start because the following file is missing or currupt:
<windows root>\system32\ntoskrl.exe
BUT WHO CARES!!!! Because YOU fixed it and got it working for me!!!! Amazing thanks! Not sure why, because the old boot.ini file looked like this:
;
;Warning: Boot.ini is used on Windows XP and earlier operating systems.
;Warning: Use BCDEDIT.exe to modify Windows Vista boot options.
;
[boot loader]
timeout=30
default=c:\CMDCONS\BOOTSECT.DAT
[operating systems]
c:\CMDCONS\BOOTSECT.DAT="Microsoft Windows Recovery Console" /CMDCONS

Hopefully this thread will be helpful to someone else down the road. Many many thanks!!!
 
#29
Yep, its like I thought.
rdisk(1) was correct after all.
I originally suggested rdisk(2) because your Disk Management screenshot showed the XP disk as the third disk, but sometimes (as in this time) Disk Management sees the disks differently than the BIOS. That's why I suggested rdisk(1) next, which worked.

Glad you got it working. :smile:

Addendum:

Actually, on second look, I see the order of the disks varied from the first screenshot you posted, till you posted the second one. Did you change the boot order in the BIOS since posting the first screenshot? Not really important, but just curious...
 
Last edited:
#30
No, but I did move the drive running XP from the secondary IDE cable to the primary IDE. Originally, I had one the primary WIN7 HDD and a storage HDD. And, then on the secondary was the old XP and a DVD burner. Would that have caused the switch? Because now its primary IDE WIN7 and XP and secondary storage and DVDburner.

Very Happy!
 
#31
Yeah, switching the cables probably caused it.
Enjoy your multiboot !

Jake