New to bootloaders...

#1
I have vista ultimate build 6000. I wanted to test drive linux. I installed freespire on a 2nd drive.
when I boot, I get GRUB, with a default os of freespire, and then windows. I tried to use easyBCD 1.51. now when I pick windows from grub I get choices of windows/freespire. I cannot boot into freespire from here it just looks at me stupid. Here is what I have in easyBCD

There are a total of 2 entries listed in the Vista Bootloader.
Bootloader TimeOut: 30 seconds.
Default OS: Microsoft Windows Vista

Entry #1

Name: Microsoft Windows Vista
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Windows Directory: \Windows

Entry #2

Name: FreeSpire
BCD ID: {1b7315a1-c6ae-11db-994b-005070e852d2}
Drive: C:\
Bootloader Path: \NST\nst_grub.mbr
Windows Directory:


how can I get rid of grub completely and just use the windows bootloader?

How do I install a new linux distribution without creating a new "grub" instance?

Thanks for any advice!

David
 

mqudsi

Mostly Harmless
Staff member
#2
OK, first, welcome to NeoSmart Technologies.

What you need to do is boot into freespire, and run
Code:
grub-install /dev/hdb1
then reboot into Windows Vista.

Use EasyBCD's Bootloader Management -> Reinstall Vista Bootloader option to get rid of GRUB from the startup.
Then delete the old Freespire entry you made in EasyBCD.

Then add a new linux entry, drive 1 partition 1.
That should work.