Problem removing boot menu (Win7 64bit & Ubuntu 12.04)

Discussion in 'EasyBCD Support' started by perastikos, Apr 29, 2012.

  1. perastikos

    perastikos New Member

    Joined:
    Apr 29, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Hello everyone!
    I first used easyBCD when I installed ubuntu 10.10 with Win7 64bit. After each of my next 2 ubuntu updates, I had problem booting my pc (boot menu did not show and it booted without asking to ubuntu). I got pass this issue by fixing the mbr following these steps http://support.microsoft.com/kb/927392.
    Unfortunately, this did not work when I upgraded yesterday to ubuntu 12.04. So, I decided to keep ubuntu's grub menu.
    My problem is when I choose win7 in grub, I get again easyBCD's boot menu which asks me again to choose between the 2 OS's.
    Is there a way to get rid of the second boot menu?
     
  2. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,601
    Likes Received:
    2
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Remove the Ubuntu option from the BCD.
    A menu is only presented if a choice exists.
     
  3. perastikos

    perastikos New Member

    Joined:
    Apr 29, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Thanks for your reply Terry, but it didn't work.
    My detailed settings are

    Windows Boot Manager
    --------------------
    identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
    device partition=\Device\HarddiskVolume1
    description Windows Boot Manager
    locale el-GR
    inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
    default {3b77af31-922a-11e1-8aab-002421102c27}
    resumeobject {9838c102-929d-11df-94a9-ee4bd09bdf84}
    displayorder {3b77af31-922a-11e1-8aab-002421102c27}
    toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
    timeout 10
    displaybootmenu No

    Windows Boot Loader
    -------------------
    identifier {3b77af31-922a-11e1-8aab-002421102c27}
    device partition=C:
    path \Windows\system32\winload.exe
    description Microsoft Windows 7
    locale el-GR
    osdevice partition=C:
    systemroot \Windows
    nx OptIn
    pae Default
    sos No
    debug No

    I removed Ubuntu from the "Edit Boot Menu" and I clicked "Write MBR" in "BCD Deployment".
    The boot menu was not removed. It had Windows and Ubuntu as options.
     
  4. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,601
    Likes Received:
    2
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    You said you were keeping the grub menu.
    Using "install Vista/7 boot loader > write MBR" puts the W7 loader back in charge.
    "edit boot menu" is all you need to edit the boot menu.
    Which version of EasyBCD are you using - what if anything is ticked in the Tools > Options page ?
     
  5. perastikos

    perastikos New Member

    Joined:
    Apr 29, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Makes sence...
    I'm using EasyBCD's version 2.1.2.156.
    My options window has the following ticked

    Options.GIF

    Must be the default ones. I don't remember changing them.
     
  6. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,601
    Likes Received:
    2
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    OK that version has a bug in the display.
    The wrong box got ticked.
    Get the very latest Beta and you'll see the tick will move from "...expert mode" to "Auto.. load ..."
    which is showing that you're not working on the correct BCD, but a backup stored in your user folder.
    Untick that option and EasyBCD will locate the "live" BCD where you'll find the entry you were trying to remove
    (but do you still want to ? seeing that you've apparently put bootmgr back ahead of grub)
    That "autoload" option gets set if EasyBCD cannot locate the BCD on the "active" partition of the first HDD in the boot sequence and you use the dialogue it uses at startup to navigate to a BCD, or if you use the File > Select BCD option.
     
  7. perastikos

    perastikos New Member

    Joined:
    Apr 29, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Downloaded it, but neither options were ticked. I left them that way.

    I tried to give EasyBCD one last try. I followed steps 3 to 7 in the guide http://neosmart.net/wiki/display/EBCD/Ubuntu, but again it booted directly to ubuntu. I can't understand what I am doing wrong.

    So, I removed ubuntu and now when I choose Win7 in grub, it takes me directly to windows.

    For the past year that I have been using EasyBCD I really liked it. My only problems were after each ubuntu upgrade and now that even bootrec.exe did not work.
    Thank you very much Terry for all your help!
     
  8. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,601
    Likes Received:
    2
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Can you summarize your current position.
    Which boot menu are you using, grub or bootmgr ?
    and which OSs can you access (or not)
     
  9. perastikos

    perastikos New Member

    Joined:
    Apr 29, 2012
    Messages:
    5
    Likes Received:
    0
    Trophy Points:
    0
    Now I am using grub and I can access both Win7 and Ubuntu. These are the only 2 OSs I have installed.
     
  10. Terry60

    Terry60 Coastline Designer Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    9,601
    Likes Received:
    2
    Trophy Points:
    38
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    But you're still seeing the second menu from bootmgr ?
     

Share This Page