Recovery CD ISO on flash can't find OS

#1
Hope I'm in the right place here...

I have a "swiss army" flash drive that has on it - among other things - the 32 and 64 bit recovery CD ISOs. I boot them with grub legacy:

title Windows 7 Recovery 64 bit
kernel /boot/isolinux/memdisk iso raw
initrd /ISOs/Windows_7_64-bit_Repair_Disc.iso

They both boot OK on my ThinkPads: T400 and T420. Both machines have healthy Win 7 Pro 64 installs.

If I boot the physical burned CD, the tool finds the installed OS. If I boot the ISO, it doesn't. I can read the OS partition and cd to it from the command line.

This has worked successfully on other machines (IIRC...) but not on these TPs.

My other booted ISOs (spinrite, etc) boot and function correctly.

Any suggestions?


[edit] If I 7zip extract the ISO files to the active fat32 partition on the flash drive, it boots and finds the OS. Hmmm. That kills the multi-boot possibilities of ISO booting, AFAICS.

[more edit] Tried the easyBCD approach. Boots OK, but doesn't find the OS either. Says "problems found" but doesn't list the OS. :frowning:

Thanks,
Z.
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
The WinPE-based recovery CDs should be loaded as WIMs for maximum-compatibility. EasyBCD can load them half a dozen ways, you're not specifying if it was WIM that you tried?
 
#4
Hi Mahmoud,

Sorry to be a pest. Per all of the above, would you expect the Recovery CD ISOs to boot and run correctly (be able to find the installed OS) if built using EasyBCD and the guide I linked above?

Thanks again,
Z.
 

mqudsi

Mostly Harmless
Staff member
#5
I could swear I replied to this thread.

If you extract the contents of the ISO to the USB and you use EasyBCD to add an entry to the WIM, you may have better success. I never had any problems with the method in the guide, and we've never had anyone else have problems; but I suppose it's possible your motherboard may have something to do with it.