same XP/Vista dual-boot problem...

#1
I've been thru the entire forum and tried most of what people with similar problems have tried, but to no avail.

I have 1 SATA & 2 EIDE drives. XP is installed on the SATA. I installed Vista to 1 of the 2 EIDE drives, which I called V:\
Set that one as the primary boot, Vistas runs fine. Set the SATA to the primary boot, XP runs fine. Try to boot XP with Vista as the primary, and I get the `missing ntldr file' error message. Copy my boot.ini & ntldr file to the Vista drive, and I get the `hard-reset' when I choose XP.

My boot.ini is as follows:
Code:
[boot loader]
timeout=30
default=multi(0)disk(0)rdisk(0)partition(1)\WINDOWS
[operating systems]
multi(0)disk(0)rdisk(0)partition(1)\WINDOWS="Microsoft Windows XP Home Edition" /noexecute=optin /fastdetect /usepmtimer
Nothing special there. I change rdisk(0) in both lines to 1, disk(0) in both lines to 1, copy the boot folder and bootmgr file from the Vista drive to the XP drive, no change.
I have XP set to boot from C:\ in my Bootloader as follows:
Code:
There are a total of 2 entries listed in the Vista Bootloader.
Bootloader TimeOut: 15 seconds.
Default OS: Microsoft Windows Vista

Entry #1

Name:  Microsoft Windows Vista
BCD ID:  {current}
Drive:  C:\
Bootloader Path:  \Windows\system32\winload.exe
Windows Directory:  \Windows

Entry #2

Name:  Microsoft Windows XP
BCD ID:  {feef9d74-c171-11db-b226-00508dd97d3f}
Drive:  C:\
Bootloader Path:  \ntldr
Windows Directory:
Any help would be greatly appreciated. I have, quite-literally, been at this non-stop for 4hours now. :sick:
 
#2
Can I second this question, as I'm in exactly the same position.

Vista boots fine from the menu, but selecting XP just causes my machine to reset. I did have a fully working Vista/XP dualboot system running, until my computer crashed after installing some new nVidia drivers. When it rebooted, the menu was gone, and XP wouldn't boot anymore.

I have 2 HDDs, one SATA and one IDE. I already had a working Vista installation on the SATA drive, so I selected the IDE drive as the boot drive in the BIOS, and installed XP. Now, if I set the IDE drive as the boot drive, XP boots, and if I set the SATA drive as the boot drive, Vista boots. I changed the BCD entry for XP to point at the F drive (where XP was installed) and I get the restart when I select it from the menu.

Any help you can give would be most appretiated!

My config looks like this:

Code:
Windows Boot Manager
--------------------
identifier              {bootmgr}
device                  partition=C:
description             Windows Boot Manager
locale                  en-US
inherit                 {globalsettings}
default                 {current}
displayorder            {current}
                        {b86cefd7-be95-11db-9b98-0015f2397f24}
toolsdisplayorder       {memdiag}
timeout                 5

Windows Boot Loader
-------------------
identifier              {current}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows Vista
locale                  en-US
inherit                 {bootloadersettings}
osdevice                partition=C:
systemroot              \Windows
resumeobject            {6cb062fd-bed3-11db-a4e1-907882332268}
nx                      OptIn

Windows Legacy OS Loader
------------------------
identifier              {b86cefd7-be95-11db-9b98-0015f2397f24}
device                  partition=E:
path                    \ntldr
description             Microsoft Windows XP
Graeme
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#3
I believe the problem comes in here cause of this. The xP install has the MBR and the NTLDR on the SATA drive. So when you boot from the EIDE drives you lose that info. So when you try to boot from Vista you will lose that info cause it isnt present on the boot drive as it should be. The only rememdy i know for this is to install XP on the EIDE disc. Other than that get a copy of PArtition Magic and partition out some space on the SATA drive for VIsta. Then you will have no problem booting between the 2 OS's.
 

mqudsi

Mostly Harmless
Staff member
#4
Hello everybody :smile:

Actually, there is a slightly "easier" but more complicated fix: you need to update your boot.ini files to contain the proper drive and partition numbers for all legacy OSes, then change the letter in EasyBCD for the XP entry to point to the drive with Boot.ini on it.
 
#5
Okay, so in my case, is my boot.ini file technically `wrong' when I boot with the EIDE hard-drive that has Vista on it 1st...? Cuz then the SATA hard-drive that contains XP is no longer at "multi(0)disk(0)rdisk(0)partition(1)"...? If so, where does it go?!? I swear I've tried every combination of disk(0)rdisk(0) several times. Do I have to change multi(0) to multi(1)? I don't really know what I'm doing here, (obviously,) so I don't really know what these values mean, exactly.

Also, I have EasyBCD pointing to my C: for XP even tho it's listed as E: when I run Vista cuz that's the only way I get the `ntldr' response. Any other drive I point to just restarts when I select XP. Should I be setting it to E:?

This shouldn't be this hard! (Not you guys, EasyBCD. You guys are doing a public service as far as I'm concerned. I just mean setting-up a dual-boot for Vista and XP in-general.)

Did I mention my Vista is 64-bit...? (My XP is 32-bit.) Please tell me that's not making a difference in this...
 

mqudsi

Mostly Harmless
Staff member
#6
No, it doesn't make a difference if it's 64 or 32 bit, EasyBCD is fully x64 compatible, and the boot.ini structure doesn't change.

Well, SATA is on another controller than the IDE right? so try multi(1)
 
#7
Nothin.
Tried multi(1)disk(0)rdisk(0), multi(1)disk(1)rdisk(0), multi(1)disk(1)rdisk(1), and multi(1)disk(0)rdisk(1) just to be sure. All hard-resets.
Any other ideas...?
 

mqudsi

Mostly Harmless
Staff member
#8
Delete all boot.ini files.
Delete all XP entries from EasyBCD.
Boot from the XP CD, enter the recovery console, and issue these commands:
Code:
bootcfg /rebuild
Back in Windows Vista, check what drive the boot.ini file is now on. Is it on the same drive with the BOOT folder or another drive?

If it's on the same drive as the BOOT folder, simply add an XP entry to EasyBCD. If it's on a different drive, add an XP entry, then go to the "Configure Boot" screen, and change the drive letter for the XP entry to the correct drive.

NB: Entering the correct drive from the add/remove screen WILL NOT WORK. You have to manually go back and change it if it needs to be changed.
 
#9
No joy. It wants an administrator password, and I don't have one on my system that I'm aware of.
Vista also didn't like that very much. It ran a ChkDsk when I restarted.

Also, if XP boots fine when I set it's hard-drive to load 1st, then don't I know that my boot.ini is correct? I know that it's either C: or E: and I've tried both.

Honestly, at this point, I think I'm just gonna stick to swapping the drive order in bios. I've spent enuf time on this to have rebooted my system that way, literally, hunderds of times. Thank you, tho. Again, not your fault. I think this should be a lot easier to do than they've made it.
 

mqudsi

Mostly Harmless
Staff member
#10
well, you could switch the master/primary, set a password on xp, then run the steps above.