Unable to boot Ubuntu in dual-boot with windows by EasyBCD

drtkm

New Member
#1
Dear All - After installing Ubuntu with its bootloader in a patition, I was unable to boot it via EasyBCD 2.3.207 (my preferred bootloader). I have installed Ubuntu after Windows and don't want to use grub on MBR of first disk. I can boot Ubuntu by Super Grub Disk but when I try it by EasyBCD, either by automatically choosing or selecting the partition manually, it end up in Grub> prompt. The following commands are also not effective :
Root=(hd0,5)
chanloader +
boot

Now I am in Grub rescue > prompt. Interestingly, I now can boot into Ubuntu by:
set prefix=(hd0,6)/boot/grub
set root=(hd0,6)
insmod normal
normal

This gives me the grub menu and I can choose any option therein. The problem is that it is impossible to do this every time for booting or use Super Grub Disk. How can I use Neogrub bootloader to do this automatically (tried it unsuccessfully by manipulating the menu.lst file).

Please help,

Thanks,

Drtkm
 

Terry60

Knows where his towel is.
Staff member
#2

drtkm

New Member
#3
Thanks Terry. No it isn't a UEFI PC. Bios mode is legacy. I have checked your link and found that I am trying to multiboot with Windows 10 with Fast Boot enabled. As per your advice, I turned it off. How should I proceed now?

With best wishes,

drtkm
 

Terry60

Knows where his towel is.
Staff member
#4
I haven't used Linux for many years now, so my knowledge is not current and I'm not in a position to offer much advice on that subject.
However, I do seem to remember seeing over the past few months a few exchanges on here regarding a problem which haas cropped up for a few users when they updated Ubuntu to a particular new release version.
Try searching the forum with the specific release number of Ubuntu giving the problem and see if you've fallen foul of the same problem introduced by a Linux format change.