Vista RC1 Failing To Boot Without RC1 ISO DVD

#1
Hey,
Just installed Vista RC1 Build 5600, Dual boot setup with XP. Vista is on a partition on a different hard drive to XP. It gives me an error before it gets into the boot manager "cannot read disc" or something like that (I can get the exact words if you need it. It then asks me to hit alt-ctrl-delete to restart comp :dead: .
I have however discovered that if I leave the dvd with the RC1 ISO in my disc drive it manages to make it to the boot manager screen and it's all good from there.
I really don't want to have to have a dvd in my computer everytime I want to turn it on. What can I do to bypass this step? (I have a friend who has his work without the ISO as I am sure most people do)
Thanks in advance,
Matt
 

mqudsi

Mostly Harmless
Staff member
#2
Hi!

First, welcome to NeoSmart Technologies!!

This should do the trick:
Boot into Vista
Grab EasyBCD @ http://neosmart.net/dl.php?id=1
Install it
Run
From the "Manage Bootloader" screen -> Reinstall Vista bootloader

Hope that helps!!
 
#3
Thanks for your help,
I've done what you said and it now sayes "cannot find BOOTMGR" "press alt-ctrl-del to restart computer".
I had a look and the Bootmgr and boot folder are in the C drive (not the hard drive vista is installed on) could this be the problem? Also the BCD text said the drive vista was using is V: (the drive with vista on) does this need to be changed to C using easyBCD?
Thanks,
Matt
 

mqudsi

Mostly Harmless
Staff member
#4
Copy bootmgr and the boot folder to drive V:
....
should work
 
#5
Copied boot folder and bootmgr from C: to V: .... No effect
Copied boot folder and bootmgr from DVD to V: .... No Effect
I tried playing around with the bios boot order to see if it was looking in the wrong hard drive, but no luck :dead: .
Any further ideas? could it be that vista can't recognize dive V: as it is a long way down the drive letter chain?
Thanks again,
Matt
 

mqudsi

Mostly Harmless
Staff member
#6
Can you tell me this:

On XP, what letter is XP and what letter is Vista?

On Vista, what letter is XP and what letter is Vista?
 
#7
After the reinstall of vista the drive letters were the same i.e.

ON XP: XP = C: Vista = V Data = Z
On Vista: XP = C Vista = V Data = Z

Hard Drive 1 = C:
Hard Drive 2 = Z:,V:
SATA Connections (not raid)

Thanks for your ongoing support, it's much appreciated.
Matt
 

mqudsi

Mostly Harmless
Staff member
#8
OK, what you need to do is "unite" the bootsectors on the two drives.

(and I don't suggest keeping experimental OSes on the same HD as data! especially when you have two of them....)

---------
Set your BIOS to "not see" your second HD by disabling in the drive configuration page.
From within XP boot EasyBCD and (re)install the Vista bootloader. Remove all entries, create an entry to XP Legacy, and an entry to the currently non-existing Vista on drive V:

Suggestion: there is a bug in EBCD 1.2, create an entry with the drive bit in the form
X:
and not
X:\

Then reboot. From the BIOS set it to not see the *first* drive and boot straight to the second.
From here boot into Vista, and select "install XP bootloader," write the MBR, and reboot.

Enable both drives in BIOS, make sure drive 1 is set to boot and NOT drive 2.
BootMGR is on Drive 1, and Vista shouldn't have any problem finding it this time around, so long as it boots from Drive 1 and Drive 1 then boots Vista off Drive 2.
 
#9
Ok here's what happened...
I followed as per your instructions to the point where I was tring to make it boot into vista off the SECOND drive having disabled the FIRST drive. It failed to boot with the first drive disabled (it just stalled on the "press any key to boot from CD or DVD..."). So I enabled the first drive and had it booting off the second drive. This booted me straight into vista (no options screen this time). I was unsure what you ment by "Install XP bootloader" but I guessed it was the option under install vista bootloader - "Uninstall vista bootloader" -(I made a backup of the bootloader before I did this)- I guessed that uninstalling vista bootloader is the same thing as installing an xp bootloader.
From here I changed the booting hard drive back to the first drive as per your instructions, this time it booted me straight into xp with no options screen.
I tried (re)installing the vista bootloader, this has the effect of booting me straight into vista if I have the ISO DVD in (otherwise it stalls) and the only way to get back to XP is to "uninstall the vista bootloader".

So what do you think went wrong? Is it possible the the second drive just doesn't have a MBR? I still have the backup of the bootloader in that intermediary stage if that helps.
Thanks again for your time,
Matt
 

mqudsi

Mostly Harmless
Staff member
#10
The second drive isn't supposed to have an MBR.

But this is good news:

*if* now when you have both drives enable and drive C: is set as first boot Vista loads immediately, you're on the right track.

Now, from Vista, add a Windows XP Entry (Legacy) with C: as the drive letter (not C:\!)
It *should* work.
Don't change any of the config, it's all perfect now!
 
#11
Unfortunatly no effect :dead:
The original problem of vista not booting without the DVD is also still there.
Here are the BCD details in each OS, can u see any issues?:
(Thanks for your ongoing patience with this problem)
VISTA

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
displayorder {current}
{508fc1ac-4f59-11db-8b8f-000e2e07a52e}
toolsdisplayorder {memdiag}
timeout 10

Windows Boot Loader
-------------------
identifier {current}
device partition=V:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
osdevice partition=V:
systemroot \Windows
resumeobject {d5d35ac0-4f7b-11db-99d3-806e6f6e6963}

Windows Legacy OS Loader
------------------------
identifier {508fc1ac-4f59-11db-8b8f-000e2e07a52e}
device partition=C:
description Microsoft Windows XP



XP

Windows Boot Manager
--------------------
identifier {bootmgr}
device partition=C:
description Windows Boot Manager
locale en-US
inherit {globalsettings}
displayorder {508fc1ab-4f59-11db-8b8f-000e2e07a52e}
{508fc1ac-4f59-11db-8b8f-000e2e07a52e}
toolsdisplayorder {memdiag}
timeout 10

Windows Boot Loader
-------------------
identifier {508fc1ab-4f59-11db-8b8f-000e2e07a52e}
device partition=V:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
osdevice partition=V:
systemroot \Windows
resumeobject {d5d35ac0-4f7b-11db-99d3-806e6f6e6963}

Windows Legacy OS Loader
------------------------
identifier {508fc1ac-4f59-11db-8b8f-000e2e07a52e}
device partition=C:
description Microsoft Windows XP
 

mqudsi

Mostly Harmless
Staff member
#12
Did you try to let Vista automatically fix the problem?

Boot from the Vista DVD, and when it says "click here to install" press the advanced options or "startup repair" or something (it changes its name every build!) on that screen.
Then select your Vista OS, and press repair startup...

And, don't worry, we're sticking to this until it works!
 
#13
ok I tried the startup repair and....
we are back to the "disc read error" without the ISO DVD and with the DVD it boots straight into vista.
I don't know if this is relevant but there is also a 'desktop.ini' now on the desktop, which automatically opens on startup with something about shell info.
When I had a look at the report from the repair diagnostic it said the vista was on disc 0 and windows directory was on "e:/windows" e: is the dvd drive with the vista dvd in it.
 

mqudsi

Mostly Harmless
Staff member
#14
I'm getting lost :smile:

At any point in the process, were you ever able to boot into Vista without the DVD and with both drives enabled?
 

mqudsi

Mostly Harmless
Staff member
#16
OK, I don't see why this is giving you such a hard time, it shouldn't be this hard unless something is wack in your BIOS/mobo and the way it is reading the primary and secondary hard drives.

This should work:

1) Disable the XP hard drive.
2) Make the LH hard drive the default boot, with the Vista DVD boot into Windows Vista.
3) Use EasyBCD to Reinstall the Vista Bootloader (Bootloader Management window)
4) That should let Vista boot by default without the CD.

We need to get this fixed first, then we can worry about the XP drive.
 
#17
ok here's a brain-teaser for you:

When the XP drive (HDD-0) is disabled I cannot boot windows (it stalls on the "press a key to boot from dvd.....")
When the XP drive is enabled I discovered that the boot harddrive is irrelevant (I tried booting from no hard drives) and that it boots straight from the DVD somehow.
Here's the bit that is interesting:
my dvd drive that has the Vista DVD is labled as E: in XP AND Vista and the Partition that has Vista is labled (In both OS) as V:. BUT I tried a startup recovery from the vista dvd and in the recovery notes I noticed that it recognised that V:frowning:vista - 24999 MB) drive was E:frowning:24999MB) drive, here are the notes as follows:

The following startup options will be added:
Name: Windows Vista (TM) Ultimate (recovered)
Path: Windows
Windows Device: Partition: E: (24999MB)

So even though Vista has named drive V: correctly in the OS. Somewhere, before (or while) the OS boots it thinks that V: is E: and is looking in E: for the Boot files, which happens to be the Vista DVD.

Let me know what you think :smile:
 

mqudsi

Mostly Harmless
Staff member
#18
OK... that helps.

Disable the XP drive. That's the most important thing: to get the Vista drive booting right.

Boot the recovery console from the Vista DVD, but instead of selecting auto repair, open a command line prompt.

Browse to \Boot folder of the DVD (it might be drive C: or E:smile: from the command prompt
Code:
cd x:\boot
and the run this:
Code:
bootsect.exe /lh all /force
then restart.

Does that work then?
 
#19
I tried what you said, it ran the process (as far as I can tell), but it is still not booting with the XP drive disabled. It booted into vista when I re-enabled the XP drive - it was booting into xp before.
 

mqudsi

Mostly Harmless
Staff member
#20
OK, something that happened to me last night gave me an idea.
Is your Vista partition set as Active/Boot?

Do you have Partition Magic or better yet, Acronis Disk Director 10?
You need to boot into it (or run it from XP), and on the Vista drive, right-click the Vista partition, and
"Set Boot"
or
"Set Primary"