win7 - ubuntu 10.10 (dualboot)

#1
Hello, I have created a dualboot system with win7 and the latest version of ubuntu, maverick meerkat.

If I boot my computer, the grub2 bootloader starts up. I can chose between default ubuntu options and Windows7. I can change some thinks in ubuntu with the linux app called ´startup manager´. But the following thing I can not change in linux.

When I choose windows 7 in the grub2 menu I am redirected to the ´Windows Boot Loader´. How can I configure my computer that when I click windows7 in the grub2 menu windows7 just starts. So I want to remove the ´windows boot loader´.

Is this possible, and how can I do this?
 

Terry60

Knows where his towel is.
Staff member
#2
Post the contents of EasyBCD "view settings"
 
#3
Ok,

Overview:
Code:
There is one entry in the Windows bootloader.

Default: Ubuntu 10.10
Timeout: 10 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Ubuntu 10.10
BCD ID: {default}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub1.mbr

Detailed:
Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  boot
description             Windows Boot Manager
locale                  en-US
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default                 {f8cbe95e-eaf0-11df-b78b-00226856016d}
resumeobject            {1f8184a2-14de-11df-9734-f08c6d8c50b0}
displayorder            {f8cbe95e-eaf0-11df-b78b-00226856016d}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 10

Real-mode Boot Sector
---------------------
identifier              {f8cbe95e-eaf0-11df-b78b-00226856016d}
device                  partition=C:
path                    \NST\AutoNeoGrub1.mbr
description             Ubuntu 10.10

EDIT,

A little history is maybe necessary:

I installed a DUALBOOT, first windows7 then ubuntu 10.10. It was working fine, but I wanted the bootloader to look better so I installed EasyBCD. Using this guide: Ubuntu - NeoSmart Technologies Wiki

I did something wrong though (I think). Because after the install I had to reboot and it gave an error saying that I had to insert my windows7 CD and choose repair.. bla bla bla..

I did not do this becaus I know that with this way I would not be able to boot into ubuntu again, so I inserted the ubuntu liveCD instead. And from there I was able to fix GRUB2..


EDIT2.
EasyBCD overview tells me that ubuntu 10.10 is default. This is not true. So it seems that there are some left over from previous install.. Maybe its best to reset the MBR. And start to fill in the entries from scratch? Or not? Maybe leave it as it is (its working fine, but it doesnt look nice!)
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
Add a W7 entry to the BCD (add new entry) and delete the Ubuntu entry.(edit boot menu)
You shouldn't get a second menu if there are no options, but you can always tick the "skip boot menu" box in the "edit boot menu" page.
If you want MS bootmgr in control, use "Bootloader Setup" > "Install Vista/7 bootloader" > "write MBR", and leave the Ubuntu entry in the BCD. (You'll need to change timeout to 0 in the grub config, to suppress it as the 2nd menu)
 
#5
Add a W7 entry to the BCD (add new entry) and delete the Ubuntu entry.(edit boot menu)
You shouldn't get a second menu if there are no options, but you can always tick the "skip boot menu" box in the "edit boot menu" page.
- I added a w7 entry to the boot.
- Deleted the ubuntu entry in edit boot menu..
- ticked the skip boot menu

rebooted..

and the grub2 menu is gone.. it just starts in win7.

So after that I unticket the skip boot menu. And this time I come directly to the windows boot loader, with only win7 choise.

So what can I do now?

Do I just have to add a ubuntu entry? And how? And I also would like to have the ´ubuntu recovery´ entry!
 

Terry60

Knows where his towel is.
Staff member
#6
OK.
I assumed you were in the grub menu because the MBR took you straight there, but now I see that your single entry bootmgr menu was in control and chaining you into grub without presenting a menu.
All you needed to do was add the W7 entry, but since I got you to delete the Linux entry, you'll need to add it back again.
Use "add new entry", linux tab, select grub2 from the dropdown and let EasyBCD auto configure.
You'll get a bootmgr menu which will give the choice of either system, and if you select Ubuntu you'll get another menu where you'll be able to choose the normal or recovery options.
If you set timeout (0) in that menu, you'll go straight to normal Ubu, and you can use a hotkey to force the second menu to appear. It used to be "esc" in grub, but i believe it's changed ( shift ?)
There's a tutorial that should explain how to do all of the grub2 stuff
http://ubuntuforums.org/showthread.php?t=1195275
 

JustinW

Super Moderator
Staff member
#7
And you probably want to opt for the interception of the second menu only if you need it. For me its nice just having Ubuntu boot straight away (though I've gone Ubuntu only now on my laptop :smile:)
 
#8
thanks terry, this is just what I wanted!

The shift button is not working though.. but I can put the grub2 menu on 1second.. thats OK to...
 

Terry60

Knows where his towel is.
Staff member
#9
How to Boot to the Recovery Mode w/o a Menu Option
  1. If you have Grub 2 set to boot without displaying the menu at all, hold the SHIFT key down until the menu displays. (In Grub it was the ESC key.)
  2. Press any key once the menu is displayed to 'freeze' it. Then arrow to the kernel you want to boot.
  3. Press "e"
  4. Scroll to the end of the "linux /boot/vmlinuz...." line. If displayed, remove "quiet" and/or "splash". Add the word "single" to the end of the line.
  5. Press CTRL-X to boot to the Recovery menu.