XP doesn't boot, guess there is no boot.ini

#1
I've Windows 7 on C:
and Win XP on D:



I've added XP partition using EasyBCD to Win 7 bootloader, changed the drive letter to D:, copied ntdlrd stuff to the drive D:



but XP doesn't boot anyway, i get a message invalid boot.ini then selecting Windows XP in boot screen.

So how to create that boot.ini with my disk setup? XP is in the drive D:\, not the C:\.
 

Attachments

Last edited:

Terry60

Knows where his towel is.
Staff member
#2
Hi Originalas, welcome to NST.
Please ready the sticky thread.
You should not point the BCD at the XP partition, but at the XP boot files, which need to be in the "system" partition (W7 in your case)
That's why EasyBCD greys the option to prevent you pointing to the wrong place!
 

JustinW

Super Moderator
Staff member
#3
ntdetect.com appears to not be present on your active system partition. You'll need to copy ntdetect.com ntldr, and boot.ini from where they are currently located in order to fix it.
 
#4
You can use [thread=642]EasyBCD 2.0 Beta[/thread] to auto-configure boot.ini. Just go to the Tools menu, and click on Auto-configure boot.ini.

Jake
 
#7
Glad to hear it. :smile:
Let us know if you have any more questions.

Jake