2 system partions (different disks) each has a boot menu

#1
Win 8.1 and Win 7 installed on separate disks on same system while other disk is disabled. Each disk has its own system partition and its own boot menu. Both systems are accessible from its own boot menu. Each boot menu fails to access the other system with error: bad or missing winload.exe; easyBCD view displays are attached.
 

Attachments

Terry60

Knows where his towel is.
Staff member
#2
Firstly, you cannot boot a later Windows from an earlier. The W7 bootmgr does not recognize the W8 winload signature as genuine.
You must boot from the W8 HDD and add an entry to the W8 BCD for W7.
Delete the W7 entry from the W8 BCD and add it again. Make sure you specify the disk letter for the W7 as W8 Explorer sees it.
 
#3
Selecting windows 7 from the boot menu on Windows 8.1 still does not work. It still has a problem finding winload.exe; however Windows 7 can be accessed from the f8 boot menu

The following is the view settings text on Win 8.1

There are a total of 4 entries listed in the bootloader.
Default: Windows 8.1
Timeout: 30 seconds
EasyBCD Boot Device: D:\
Entry #1
Name: Hard Drive
BCD ID: {cac52f9b-bc68-11e3-8952-8410fdcc1da2}
Device: Unknown
Bootloader Path:
Entry #2
Name: CD/DVD Drive
BCD ID: {cac52f9a-bc68-11e3-8952-8410fdcc1da2}
Device: Unknown
Bootloader Path:
Entry #3
Name: Windows 8.1
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.efi
Entry #4
Name: Windows 7
BCD ID: {cac52fa3-bc68-11e3-8952-8410fdcc1da2}
Drive: D:\
Bootloader Path: \Windows\system32\winload.exe
 

Terry60

Knows where his towel is.
Staff member
#4
How is the W7 partition "D" from W8 if the boot device is also "D" and you say you are booting from the W8 disk ?
 
#5
Current status:
Didn't have much installed on win 8.1 so decided to reinstall.
That got rid of the system flag on the Win 7 disk.
Set Win 7 to skip the boot menu
Win 8.1 now shuts down my system when Win 7 is selected

There are a total of 4 entries listed in the bootloader.

View settings under Win 8,1 are now:

Default: Windows 8.1
Timeout: 30 seconds
EasyBCD Boot Device: D:\

Entry #1
Name: Hard Drive
BCD ID: {cac52f9b-bc68-11e3-8952-8410fdcc1da2}
Device: Unknown
Bootloader Path:

Entry #2
Name: CD/DVD Drive
BCD ID: {cac52f9a-bc68-11e3-8952-8410fdcc1da2}
Device: Unknown
Bootloader Path:

Entry #3
Name: Windows 8.1
BCD ID: {current}
Drive: C:\
Bootloader Path: \WINDOWS\system32\winload.efi

Entry #4
Name: Windows 7
BCD ID: {cac52fa9-bc68-11e3-8952-8410fdcc1da2}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
 

Terry60

Knows where his towel is.
Staff member
#6
You now have both W7 and W8 specified as being on C.
Delete the W7 entry from the W8 BCD and add it again, giving it the same letter that W8 Explorer gives to the W7 partition.
Don't skip the W7 boot menu.
When you are dual-booting W7/8 from W8, you are using the W8 BCD.
W7's BCD is not involved at all and anything you do in there will have no effect.
However, if you ever want to boot from W7 directly (should your W8 HDD fry e.g.) you'll want that BCD to be usable. Just delete any W8 entry in there (it can't be used to boot W8 in any case) and with only one entry, no menu will be presented.
 
Last edited:
#7
I can still boot to Windows 7 through the menu obtained by pressing the F8 key during the boot process, or by placing its disk first in the BIOS boot order

After doing the above, the Windows 8.1 boot menu was the text version instead of the graphic version. However, the rusults are the same; selecting the Windows 8.1 option boots to windows 8.1 and selecting the windows 7 option presents the same text display as earlier; it is as follows
----------------------------------------------------------------------------
Windows failed to start. A recent hardware or system change might be the
cause. to fix the problem

{instructions to "repair" from the installation disk.}

Files: \windows\system32\winload.exe

status: 0xc0000359

Info: tThe operating system couldn't be loaded because a required file is
missing or contains an error.

Enter = OS selection ESC= UEFI firware setings
----------------------------------------------------------------------------
After a short time of doing nothing, the systems shuts down.
Selecting ESC enters the BIOS settings.
Selecting ENTER returns to the boot menu.

Here is the boot EasyBCD view display

There are a total of 5 entries listed in the bootloader.

Default: Windows Boot Manager
Timeout: 30 seconds
EasyBCD Boot Device: D:\

Entry #1
Name: Windows Boot Manager
BCD ID: {default}
Device: \Device\HarddiskVolume2
Bootloader Path: \EFI\Microsoft\Boot\bootmgfw.efi

Entry #2
Name: Hard Drive
BCD ID: {c53a01cc-c1b2-11e3-be8d-806e6f6e6963}
Device: Unknown
Bootloader Path:

Entry #3
Name: CD/DVD Drive
BCD ID: {c53a01ca-c1b2-11e3-be8d-806e6f6e6963}
Device: Unknown
Bootloader Path:

Entry #4
Name: Windows 8.1
BCD ID: {current}
Device: locate=\Windows\{72820311-c1cd-40d3-aab0-00783cf97580}
Bootloader Path: \Windows\system32\winload.efi

Entry #5
Name: Windows 7
BCD ID: {8cd19cd4-c1b3-11e3-be8d-00133b0ecd31}
Drive: D:\
Bootloader Path: \Windows\system32\winload.exe
 

Terry60

Knows where his towel is.
Staff member
#8
OK, you're in the same position as me.
W8 UEFI/GPT cannot dual boot another OS (even a W7 UEFI/GPT like mine) with secure boot turned on in the UEFI BIOS.
Disable secure boot and your dual-boot should work fine.
 
#9
There isn't a direct way to disable Secure Boot; when the Secure boot option is selected, the next screen lists as Enabled no matter what the setting of the only option on the screen. An option for OS Type is offered with two possible selections: "Windows UEIF mode" or "Other OS". There is also a "Compatibility Support Module"; these settings seem to make no difference.
 

Terry60

Knows where his towel is.
Staff member
#10
Here's the extract from my ASUS Boot Features User Guide

Secure Boot
Allows you to configure the Windows® Secure Boot settings and manage its keys to protect the system from unauthorized access and malwares during POST.
OS Type [Windows UEFI mode)
Allows you to select your installed operating system.
[Windows UEFI mode] Executes the Microsoft® Secure Boot check. Only
select this option when booting on Windows® UEFI mode or other Microsoft Secure Boot compliant OS.
[Other OS] Get the optimized function when booting on Windows®
non-UEFI mode, Windows® Vista/XP, or other Microsoft® Secure Boot non-compliant OS. Microsoft® Secure Boot only supports Windows® UEFI mode.
Secure Boot Mode [standard]
Allows you to select how the Secure Boot prevents unauthorized firmware, operating systems, or UEFI drivers from running during boot time.
[Standard] Allows the system to automatically load the Secure Boot keys from
the BIOS database.
[Custom] Allows you to customize the Secure Boot settings and manually
load its keys from the BIOS database.
This item only appears when you set OS Type item to [Windows UEFI mode]

It only took me a few seconds to disable it, though it was a few months ago, so I don't remember exactly what I did, but it must have been very simple and intuitive. (Sorry the OCR on my scanner hasn't formatted it very neatly)
secure.JPG
 
Last edited:
#11
The boot issue is resolved, but one new problem

Steps taken.
Set following BIOS boot options
Launch CSM -- Enabled
Boot Device Control -- UEFI & Legacy OpROM
Boot from Network Devices -- Ignore
Boot from Storage Devices -- Both, UEFI first'
Boot from PCIe/PCI Expansison Devices -- Legacy OpROM first
Secure Boot\OS type -- Other OS
(Secure Boot State -- Enabled) cannot be selected
BIOS boot drive sequence option lists only the Windows 8.1 disk and the DVD
and neither is indicated as UEFI

Windows 8.1 was reinstalled due to a missing BCD
only two partitions were created on the Windows 8.1 disk
Partition 1 -- "System Reserved" receives the system flag
A boot menu with two options was generated
Windows 8.1 (default) and Windows 7
either selection boots to the indicated OS with no problems
The "System Reserved" Partition is hidden to Windows 8.1
The "System Reserved" Partition is visible to Windows 7
Windows 7 assignes a drive letter (D) to the "System Reserved" partition

The "System Reserved" drive letter can be reassigned to get it out of the way.
But, in my opinion, it would be better if it were hidden to Windows 7.

Is there a way to make the "System Reserved" partition hidden to Windows 7?

Thanks for your time with all of this.
Nelson
Windows 7 disk Management.JPG
 

Terry60

Knows where his towel is.
Staff member
#12
Just go into Disk Management and remove the letter.