3 HDd's: XP,Data and Win7 _wont't boot now if data drive is connected

#1
I had to do a repair on XP pro sp3 and use BCD to get Win 7 Home (64) to fix my duel boot.
PC goes to a blank screen with the Data drive connected, otherwise the duel boot works Ok.

What can I do to getall 3 hdd's to work together?
 

Terry60

Knows where his towel is.
Staff member
#2
Are these drives IDE, SATA or a mixture ?
Is/are your IDE drive(s) jumpered correctly ?
Have you checked the BIOS HDD boot sequence ?
When do you get this blank screen ? Before or after making a boot selection ?
 
#3
Are these drives IDE, SATA or a mixture ?
Is/are your IDE drive(s) jumpered correctly ?
Have you checked the BIOS HDD boot sequence ?
When do you get this blank screen ? Before or after making a boot selection ?
All drives including two dvd drives are SATA and are jumpered correctly.
Boot sequence seems to be OK because I can boot into either OS (except as stated above when data hdd is connected).
Did some testing and I can boot into Win7 with Data drive connected.
When booting to XP blank screen comes up after WindowsXP logo comes up.

When in EFI BIOS the problem Data drive has a wierd designation: AOSI (no colon) WD1002FAEX-00Z3A0
The other two HDD's are: SATA: WDC WD6000HLHK-01JJPVO
aLL are WD 10,000K DRIVES.

If I try to boot with the data drive I get>>NTLDR is missing.
If I try the 2nd SATA drive I get>>>BOOTMGR is missing.\
I can only boot with the first SATA drive on the EFI BIOS menu.
 

Terry60

Knows where his towel is.
Staff member
#4