Add OS on GPT disk to MBR boot menu.

#1
My primary desktop (ASRock 970 Ex3 UEFI) has Win 7 Ult installed on a MBR drive. I used EasyBCD when I was dual-booting with XP. Recently I added a new large drive an formatted it as GPT witih the EFI and MSR partitions. With the GPT drive as the only connected hdd, I installed Win 7 Pro SP1 x64 to a new 60GB partition, with the intention of upgrading to W10. It installed just fine. I set the “Windows Boot Manager” as the first boot choice in the UEFI BIOS, and 7 Pro starts normally on cold boot, as long as there is only one drive installed.

After plugging in a second hdd, however, Windows fails to boot. It immediately went into Startup Repair, after which I get a B&W screen saying something like “Device required for startup is missing.” (IIRC, the error msg was 0xC0000225). Several repair attempts had the same result. If I unplug the 2nd drive, the Win 7 will boot normally from the WBM. The second drive works fine with my existing Win 7 Ultimate installation, so I know the drive is OK.

It looks like the Windows UEFI boot process is fatally flawed, dependent on the original drive configuration at the time the OS is installed. Since I still have my original MBR installation on the old disks, I'm wondering if I can just add Win 7 Pro to my existing BCD on the MBR drive. Will that work, even tho 7 Pro is on the GPT drive?
 

Terry60

Knows where his towel is.
Staff member
#2
That should work.
I have UEFI GPT SSD W7/8.1 dual boot and to try W10 I installed it on an MBR HDD and booted both the SSD OSs from its MBR BCD.
It worked fine loading both with the winload.exe instead of winload.efi.
Stopped using W10 and reverted to the original UEFI dual-boot with no problem.
 
#3
That worked. I guess I'll have to keep a MBR disk in the system as the boot drive until I can learn more about UEFI boot. If anyone can explain why the UEFI boot would fail when a second hdd is added, I'd sure appreciate it. Perhaps it changes the drive numbering the UEFI setup depends on.
 

Terry60

Knows where his towel is.
Staff member
#4
I would guess that it's something to do with choosing "WBM" in the UEFI, and that being associated with the new OS.
Have you tried picking something more drive specific ?