Boot loader corrupt

I got a big problem on my hand, I may lose everything on my harddrive if I don't fix it. It's life or death right now.

So this is what happened, I installed Linux from a usb flash drive, it went well, when I restarted, the boot loader was there, and I booted up Linux normally. But I get a problem where when I try to install an app from software manager, it'll download half way, or almost half then suddenly stop. I always get this prob (I've installed Linux like 3-4 times on this HDD so far)
I restarted my computer to get into windows 7, but the bootscreen is corrupted, saying the partition doesn't exist, and Im able to type in commands. Says Grub rescue on the left of the command lines.
I tried using the recovery partition to use startup repair to fix the boot, but it isn't working this time.
All I can do is boot Linux from my usb flash drive, and hope for help somewhere on a forum.

I remembered that I installed Linus before, so now I have two partitions for Linux now. They both showed up in the boot loader. I might be able to use Gparted on Linux to fix my partitions.
Screenshot of gparted:

The two 58 GB partitions are my Linux partitions. The OS partition is my main one with windows 7 installed on it.

If anyone can help me with this problem, it'll be the nicest thing anyone can do!


Problem solved!! I'm finally back on Windows 7, removed the Linux partition, restored my boot to normal.
My solution:
Using Linux from my usb flash drive, I ran a command in the terminal:

sudo apt-get install lilo sudo lilo -M /dev/sda mbr Then I restarted, and the boot menu was working again, but its the Linux grub menu. When I loaded up windows 7, I would get a black screen with my cursor on it. So I restarted, launched my recovery partition and did a system restore from a few days ago. Now Im able to get into windows 7 normally :smile:
I removed the Linux partitions, got all my space back. If I do a Linux install, I'll either do Mint4win, or what someone suggested, Knopper.