Boot Manager no linger opens legacy OS and returns strange message

#1
I need to dual-boot Windows-7 and Windows-ME. I have a system hard drive partitioned with two partitions, one for Win-ME (FAT 32) and the other for Win-7 (NTFS). The Win-ME system was installed first and was operating properly. After installing Win-7 on the other partition the computer would only boot into Win-7. So I installed EasyBCD 2.2 and was then able to boot into either OS. It seemed to be working OK, so I spent most of the day installing software on the Win-7 system. All the software (much of it old) installed and seemed to work properly on the Win-7 system.

I then attempted to boot into the Win-ME system (the Win-7 boot loader menu had not changed and showed both systems, as before). But instead of loading my Win-ME system, the screen displayed the following message in a DOS format:

GRUB4DOS 0.4.5c 2012-06-19. Mem: 638K/2038M/0M, End:3548DB

[ Minimal BASH-like line ending is supported. For the first word, TAB lists possible command complications. Anywhere else TAB lists the possible complications of a device/filename. ]
grub>

Pressing the TAB key returns a long list of English words that have no meaning for me.

I tried many things. Uninstalled all the software on Win-7, no help. Reinstalled Win-7, no help. The Win-7 boot loader menu still shows both OSs but the same error message displays when I select the Win-ME OS. If the Win-7 OS is chosen it boots normally to Win-7.

I am at my wits end. Can anybody help?