Boot Manager non-existent

#1
Hi,
My computer was infected with TDSS Alueron. I ran Kaspersky TDSSKiller and it by default offered to skip it but I chose to delete it it instead.
After restarting the computer did not boot. I have tried system restore, fixmbr, fixboot, none worked. rebuildbcd offered 0 installations.
I loaded a Ubuntu disc and used ms-sys to fixmbr but still nothing.
I decided to follow the "Nuclear Holocaust" instructions on the NeoSmart website Recovering the Windows Bootloader from the DVD - EasyBCD - NeoSmart Technologies Wiki
After running del C:\boot\bcd it told me that that the directory boot did not exist! So I ran mkdir boot and kept following the rest of the instructions but it still did not work.

I have a clone of the computer on a harddrive, and if I run rebuildbcd while that external hard drive is plugged in it offers me to add the clone as a windows installation. So this made me think maybe I can recover the boot folder from the old one? Something like cp L:\boot C:\boot
Unfortunately L:\boot also does not exist, which is weird since it boots fine and shows up when I run bootrec /scanos

I'd greatly appreciate any help.

Lastly, I think it is important to mention:
I have a gateway and ever since the problem started the logo that shows up when I turn up the computer has been different (usually it says gateway now it says acer).
Also I have a hidden partition on the computer to restore windows to factory defaults but I can't access it. When I press Alt + F10 (recovery) on boot it tells me that the boot manager is missing. It does not even let me run memory diagnostics.