Boot problems

#1
A few months ago i first installed Windows Vista on my IDE hard-disk to test it out. I was pretty satisfied and started using it as main OS. I then ordered a Seagate SATA 10.000 RPM Raptor. Then installed Windows Vista on it. I dindt format my IDE drive so i could easy'r copy over my personal files.

I then got during booting a Windows Vista Boot Loader with 2 Vista's. I tried removing and fixing it with EasyBDC but the only thing that happend was that the second Vista boot was removed. But the MBR is still on the IDE disk and thus i cant format that drive now i copy'd the personal files.

Is there a solution to move the MBR from the IDE disk to the SATA disk without having the format my SATA disk. Or can I somehow format the IDE disk without losing the MBR?

Thank you!

Alexander van der Kolk
Netherlands

Here's the data EasyBCD gives me:

Code:
Windows Boot Manager
--------------------
identifier              {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device                  partition=D:
description             Windows Boot Manager
locale                  nl-NL
inherit                 {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
resumeobject            {f2a03395-de34-11db-9372-f8e0d4552b13}
displayorder            {46481285-50ba-11dc-9bb1-001109c18812}
toolsdisplayorder       {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout                 30

Windows Boot Loader
-------------------
identifier              {46481285-50ba-11dc-9bb1-001109c18812}
device                  partition=C:
path                    \Windows\system32\winload.exe
description             Microsoft Windows Vista
bootdebug               No
osdevice                partition=C:
systemroot              \Windows
nx                      OptOut
pae                     ForceDisable
sos                     No
debug                   No
 

mqudsi

Mostly Harmless
Staff member
#2
Hi Kolky, welcome to NeoSmart Technologies.

You can edit your messages to update them with new info, you don't need to create a second post.

To reset the MBR on the drive:
Boot from the Vista DVD.
Repair Options
Command Prompt:
Code:
bootrec.exe /fixmbr
bootrec.exe /fixboot
bootsect.exe /nt60 all /force
That should do the trick.

Good luck, and let us know how it goes.
 
#3
Sorry for the late reply.

I ran the commands you said. It seems faster and the second boot option is removed from my boot menu. But i still can't format the second (IDE) drive. Still says its a System Disk :frowning:

Would it work if i did the same commands but first unplug the IDE drive or is that just nuts?

Addendum:

Hmm maybe is this a solution:

1. First remove the Vista Boot Loader
bootsect.exe /nt52 ALL /force
2. Format the Vista Install on the IDE drive
3. Re-enable the Vista Boot Loader so the SATA disk boots
bootsect.exe /nt60 ALL /force

This is all just Theory-Crafting, i want to hear your answers first on this solution!
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#4
You need to change the drive order to stop the IDE drive from being drive 0.