Bootloader corrupted, no drives being detected

#1
I've got a Dell Studio 15 laptop with a 320 GB SATA HDD. I have 5 partitions on it:

i] Partition 1 [80GB, Windows Vista]
ii] Partition 2 [50 GB]
iii] Partition 3 [50 GB, Linux (openSuSE)]
iv] Partition 4 [102 GB]
v] Partition 5 [15 GB]

(the sized mentioned in the brackets are somewhat approximate, but accurate enough for all practical purposes).

I installed EasyBCD because somehow the GRUB installation failed when I was installing openSuSE and i just couldn't boot into openSuSE. In EasyBCD, first I added a NeoGRUB entry and then removed it, and added an entry from the 'Linux' tab, with GRUB as my bootloader. I picked up a drive which I THOUGHT was the correct drive, but that choice MIGHT HAVE caused this problem. The entry I picked up listed the size of the drive as '0'. Thinking that since Windows cannot read ext3 drives without additional drivers [which i hadn't installed], i thought this must be the correct drive.

Anyways, now, when I boot I get two options:

i] Microsoft Windows Vista
ii] openSuSE

When I pick Windows Vista, it shows me a BSOD saying that Windows detected an error and stopped. The only technical info that is given is 'STOP: 0x00000007B (a few hex numbers here)', and it restarts. I've tried booting in safe mode, and all other options listed.. none of them works.

Repairing: When i tried repairing using the Windows Vista DVD,

i] There is no bootsect.exe
ii] The Windows Vista DVD does not even detect an installed OS.
iii] bootrec.exe /fixbcd says that '0 operating systems were detected'.
iv] The worst thing is, when I try to reinstall Windows, the installer says that it 'Cannot retrieve information about the disk'.
v] I cannot use System Restore.
vi] When I go into the console and type in C: and then 'dir', the listing shows me a very small list of files compared to what I actually have.
vii] Trying to open D:, results in the console screen crashing after I've typed in 'dir'.

Please help me out.. even if i try to reinstall windows, i cannot seem to be able to do anything. I have no clue what's going on.

Also, when I select 'openSuSE' as my option, it loads some hardware testing application which tests my hard disk and memory... what is that thing?
 

JustinW

Super Moderator
Staff member
#2
Run "chkdsk c: /r" and "chkdsk d: /r" from the command prompt. Your disk(s)/partitions appear to be corrupted. You may want to consider booting from your opensuse live disc to rescue important data to a backup device. It might be time for a wipe of the whole drive for re-install.
 
#3
Run "chkdsk c: /r" and "chkdsk d: /r" from the command prompt. Your disk(s)/partitions appear to be corrupted. You may want to consider booting from your opensuse live disc to rescue important data to a backup device. It might be time for a wipe of the whole drive for re-install.
i'm guessing that's what the situation seems to be like.. however.. could you suggest me a good software to do a complete wipe? Maybe it's just me, but every software i've used till now which deals with hard disk [partition managers, os installers] have had problems with the partition table of my hard disk.

For example, YaST2 [the suse installer] gives me the error:

"The partitioning on disk /dev/sda is not readable by the partitioning tool parted, which is used the change the partition table.

You can use the partitions on disk /dev/sda as they are. You can format them and assign mount points to them, but you cannot add, edit, resize or remobe partitions from that disk with this tool"

Also, GRUB fails to install with the error "No such partition hd0(0,4)".

Both these errors happened when my laptop was fresh from the factory.. i never tinkered with anything at all then.

I'm assuming DELL follows some custom partitioning scheme with a few tricks with the table here and there [all companies are known to somehow twist convention and standards] which is causing all these problems.

Given that, I want my hard disk to be COMPLETELY WIPED as in NO PARTITION TABLE AT ALL. And then, I'll partition and format it using a tool which completely respects standards and convention and will ensure that my hard disk shall work with other softwares without problems. Any suggestions as to what I should be using?
 

Terry60

Knows where his towel is.
Staff member
#4
Try reinstalling Vista, but at the partition allocation stage, use the option to do a full format (not quick) of the entire HDD. The full will take a very long time, but will check-out the whole disk surface. Then from your running Vista, shrink the partition to the size you want, and partition the remaining HDD into the structure you want, and let Linux format the space you install it into, itself.
I've installed W7, XP and Ubuntu into spaces allocated from Vista disk management, and they all work just fine.
 
#5
Well.. the Vista installer never GOT to the partitioning part, it just quit after I clicked on 'Install Now' saying 'the disk could not be recognized'. Well, I just downloaded the Ultimate Boot CD and completely wiped out my hard disk and then used Paragon's Partition Manager to create partitions and then installed Vista and suse side-by-side. It's working great now.. even with SuSE, the GRUB installation did not fail and I was also able to use GRUB as a bootloader for Windows [i'm chainloading from 1 GRUB installation in hd0(0,2) to another in hd0(0,1)].

I don't know what DELL does in it's factories.. but here's one suggestion: Wipe out your disk the minute you get it from them and start over again..
 

JustinW

Super Moderator
Staff member
#6
Yes, I recommend that. First thing I did the day I got my laptop. It gets rid of all the stuff you didnt want in the proccess and gives you a chance to make a backup image at that state should you need to start over without having to re-install.