Can't boot into anything after “Write MBR”

#1
PC: HP 110-430 Desktop PC
OS: Microsoft Windows 10 (64-bit)

After upgrading my windows 8.1 install to windows 10 about a week ago (week ago), I decided that I no longer wanted the Windows/Ubuntu dual boot I had setup. So, in an attempt to delete GRUB and set the bootloader back to the windows bootloader, I downloaded EasyBCD and fiddled with it a bit before finding the "Write MBR" option. I figured that would allow me to boot directly into windows, or at least delete Ubuntu's GRUB Bootloader, so I could use one of my many windows install DVD's to set the bootloader to a windows one. Unfortunately, I'm an idiot, and after doing that, I can't boot into anything. I've tried everything I could think of or find on Google to get it to boot into absolutely ANYTHING.

I've tried boot into every one of the boot options, including the main boot menu, but none of them load. instead, it shows me a loading screen that displays some mobo info as if it were loading a boot option I selected, but it hangs there. Maybe it was just taking its sweet little time right? Wrong! I let it sit for hours, still nothin'.

HP has a "solution" where you hold the windows key + B for one second as you start up the pc, and it should start a bios recovery. Feeling hopeless, I tried it, hoping that it would do SOMETHING. Of course, it didn't boot into that either. Just a black screen.

Finally, I learned that sometimes problems like this could be cause by hardware issues, and a lot of the times its the hard drive. I highly doubted that it was a hardware issue seeing as I bought this PC late last year (around November or December of 2014) but I removed the hard drive just in case and started my computer. Same result. FML.

Can someone, anyone, help this poor idiot get his baby up and running again? I don't have the money or the confidence in their abilities to give it to Geek Squad or anyone else for that matter and let them have a go at it, so i'm depending on the internet :<
 
Last edited:

mqudsi

Mostly Harmless
Staff member
#2
Hiya SnaiLegacy,

You're actually not an idiot at all (of course), Write MBR normally would indeed accomplish just that. But it only writes the MBR, it does not deploy the boot files. In your case, the boot files must have been missing.

You can try our boot recovery instructions at http://j.mp/BcdRepair and see if that helps any?
 
#3
hey, thanks for replying!

unfortunately the instructions dont work for me; when i wrote "can't boot into anything" i meant ANYTHING

i can't boot from DVD'sbecause the computer hangs before it can do so, and i cant acess any boot options-- including the boot menu-- meaning i can't boot from USB either :<
 

mqudsi

Mostly Harmless
Staff member
#4
Is this a UEFI machine?
 
#5
do you mean if it's able to boot using UEFI? because i think it can. at the same time though, i think it boots using the BIOS normally.
i'm not actually sure as i'm not very saavy on those subjects.

the PC came with windows 8 (or 8.1, but i might've upgraded and i dont remember if it was there all along or not) so i think it could be UEFI by default.
but again, i'm not very knowledgeable on the subject.
 
#6
OKAY so i fixed everything. found out that my PC is actually UEFI, btw
sadly, over 1TB of data was erased...all my files, videos, programs...gone. its so bittersweet because my PC works but so much was sacrified ;_;

how'd i fix it you ask? well, i remembered that i had a 2TB external HDD made by WD-- the same company that made my PC's default HDD-- and it's pretty big, so i figured there was some type of adapter or something inside the big shell that allowed a full sized HDD to connect to a PC via USB, so i opened it. and i was right.

i used that adapter to connect my PC's HDD to my laptop to check for errors and what not. found out the MBR of my PC's drive was corrupted, which is, i guess, why my PC wouldn't boot.

anyway, after trying everthing i could to repair it, i gave up and just took my 2TB hard drive and used a tool built into windows to make a recovery disk, and put it on the 2TB drive. i attached the 2TB to my PC's SATA0 slot and booted it up. fixed the boot and mbr just in case, and after a little formatting and extra tinkering, re-installed windows 10.

but...when the windows tool made the recovery disk, it erased ALL of the other data on my drive. I made a partition just for the recovery, but it formatted the entire disk anyway. i hate everything but i'm also happy my PC is alive. still gonna keep my old PC HDD, hopefully i can fix it someday.

thanks anyway!!