Can't boot the second Windows from external hard drive

Hello everybody.
My appologies for possibly not very good English.
I have a very strange problem. I have installed Windows 8.1 x32 on the first partition, and Windows 8.1 x64 on the VHDX on the second partition with GImageX and system tools. Then I created BCD record on my USB Hard Drive by EasyBCD 2.2. Windows from the first partition worked great, but Windows from the VHDX couldn't boot whatever I did. But on another computer it booted fine.
Some time after that, I upgraded EasyBCD to version 2.3. Then I reset my BCD configuration and set up all the records again. Then my computer even couldn't boot into loader. After some tricks (I even don't know how) I have managed to make my computer to boot into the first Windows. But the second was still not working.
Then I tried to install Windows x64 as directly as the first one, but on the second partition. It wasn't working, too.
When I tried to install Windows onto the another external hard drive, it haven't also worked.
It is always the same error: 0xc000000f (file /windows/system32/winload.exe is missing), though it is on its place.
What can I do?
Thanks in advance.

Oops, I forgot something. For the first time VHDX couldn't load with something like "couldn't find the device".
And one more: in the virtual machine my last configuration boots well.
Last edited by a moderator:


Mostly Harmless
Staff member
It sounds like a clash between EFI and non-EFI, you can't load winload.exe from the EFI bootmgr boot menu (and it'll give a stupid error about the file not being found when it's there, alive and well).
I guess you are rigth. The computer that could load the second Windows seem to have the EFI. But my computer does not have the EFI. Would you tell me how to fix this silly error?