Can't boot Yosemite without Unibeast USB key

#1
Hello,
Herein lies my problem.
I have a Dell Inspiron One 2310 All in One Computer with all standard spec’s Apart from a replacement 1 TB HDD and 8 GB DDR3 Ram rather than the 4 GB that it originally came with.
I have successfully ran most versions of OSX 86 Hackintosh and they all booted well through my MBR using EasyBcd, right up to Mavericks 10.9.5 using Unibeast with MBR Fix & Multibeast to install and do post install fixes.

I took the jump to upgrade from a perfectly solid working install of OSX86 10.9.5 Mavericks to a 8GB Unibeast USB install of 10.10.1 Yosemite.
I can boot easily into Yosemite while booting from the Unibeast USB key but when I try to boot direct from MBR (EasyBcd) without the USB I get "Can't find mach_kernel".
I think "mach_kernel" ended from 10.9.5 onward and so, in Yosemite it is called simply "kernel" and so why would my system at boot be looking for mach_kernel.
I triple boot Windows 7, Ubuntu 14.04 and OSX86 using EasyBCD as my boot manager and have never had a problem like this with any other version of Hackintosh going right back through several versions.
When trying to boot to hdd direct I get "Can't find mach_kernel" and it shows as boot version "Darwin/x86 boot v5.0.132 - Chameleon v2.0-RC4 r684. Build date :2009-12-10 22:56:28."
When booting cleanly via Unibeast USB Pen Drive it shows the boot loader to be “Darwin/ x86 boot v5.0.132 - Chameleon v2.2svn r2463 Build date: 2014-11-02 12:50:25”
I’ve tried installing the latest Chimera 4.0.1 and the latest Chameleon 2.3 svn into my Yosemite install and still failed to boot.
I have also attempted to cold boot into Yosemite via Grub 2 loader in my Linux Ubuntu 14.04 install and it posts the same Fail message namely "Can't find mach_kernel".
Thinking I may have a busted MBR, I booted to my Windows 7 install disc and then via repair/terminal I ran the commands “Bootrec /FixBoot”, “Bootrec /FixMBR" & Bootrec /RebuildBCD and I've also tried deleting and re-installed all my three boot entries in EasyBcd.
When I access my Windows 7 partition from Yosemite desktop and look in a file called ”bootmgr” I see “Last login: Tue Dec 9 21:02:16 on ttys000
Jims-Mac-Pro:~ jimbrown$ /Volumes/Windows\ 7/bootmgr ; exit;
-bash: /Volumes/Windows 7/bootmgr: cannot execute binary file
logout [Process completed]” Then same message in a file called “BOOTNXT”
I also see in Windows 7 root a series of files named ANG (AutoNeoGrug by any chance?) ranging from 0 to 10.

Where to go, what to try next?
Any and all help will be very much appreciated.
Thank You in Advance.
Jim.
 
#2
Is there no support here???

---------- Post added at 03:39 PM ---------- Previous post was at 09:46 AM ----------

Is this the "NeoDumb" forums by mistake, rather than the NeoSmart forums?