Can't Create Bootable External Media - BCD 2.0.2

I wanted to “Create Bootable External Media”. I have a 4GB USB flash drive I’m trying to use. I go to Bootloader Setup, then under Create Bootable External Media and select the USB drive, then click - Install BCD. First of all the USB flash drive has to be formatted FAT16 or it won’t even try to work (I figured that much out), but even then it doesn’t work right. It says EasyBCD is applying the selected action… then says it was created successfully and asks Would you like to automatically load the newly-created BCD store in EasyBCD now. I select Yes and it gives an error – Unable to obtain access to the BCD…

Then when I try to look at the USB drive via Windows Explorer it says it’s not formatted and needs to be formatted before I can use it. I can format it again and read/write to it fine but as soon as I try to install BCD on it again it losses it’s format again every time. What’s up with that?


Super Moderator
Staff member
The flash drives the culprit most likely. There must be a problem with its memory chip. I too have been unfortunate with USB drives in the past (I have an 8GB lying around that I never use.... it corrupts everything I put on it). Try another USB drive to see if it works.


Mostly Harmless
Staff member
The reason you didn't see anything anywhere that said EasyBCD requires FAT16 is simple - because it doesn't.

EasyBCD supports FAT32 and NTFS for creating bootable partitions. I've experienced such symptoms as you described in the past with a USB drive that I used during the development of EasyBCD. It turned out to have a buggy controller. While the actual flash disk was OK, the mass storage USB controller was not.
Ok I tried another flash drive (Memorex 1GB) and I got further this time. It loads the bootable files on the drive without loosing it's format and I can see the files there but it still wont boot from the USB drive. I tell the computer to boot from USB and it tries and says "Disk Error - Press any key to continue".

I guess I could have another flakey flash drive but I've been using this one for years without any problems.


Mostly Harmless
Staff member
This isn't an issue with the flash disk. Most likely it's because of an incompatibility in the filesystem.

While I *did* say that EasyBCD supports FAT32 and NTFS, there are a number of catches. Certain versions of Windows XP will format a USB in a way that is incompatible with the Windows MBR code.

Please format the USB as NTFS from a Windows Vista or Windows 7 PC, then use EasyBCD's "Create Bootable" feature again.

Good luck and do let us know how that goes.
Ok, I got it to work formatting it as NTFS as you suggested but only when using a 3rd (borrowed) flash drive. My (Memorex) flash drive almost worked formatted that way. It does everything except boot into XP. It gives the error - Invalid Boot.ini file. I added the Windows NT/2k/XP/2k3 boot entry and left the “Automatically detect correct drive” box checked as your instructions stated to do. I reformatted it and re-added the boot entries several times, but it always fails to boot into Windows XP using this USB drive as bootable external media. Anyway, it’s not a big deal. If you know what’s wrong go ahead and tell me but if not, I have another solution in an external USB hard drive and it works so I have a solution if I need it.

Thanks for your help by the way.


Mostly Harmless
Staff member
Ah yes, that won't work.

EasyBCD will create a boot.ini file on your local disk and not on your USB. It's scheduled to be fixed in 2.0.3.