cant make recovery usb

#1
hi
i just purchased the windows vista easy recovery essentials. i downloaded it to my usb, went to deployment on bcd highlighted the proper drive for the usb (d:smile: and clicked install. it installed a folder titled "boot" then when clicking "yes" as the instructions tell me to it doesnt complete. i then tried the process again and for the second time with a brand new usb when i go to open the drive it tells me its unreadable or corrupted! i had thought that the first time i tried this that maybe it was the usb so i purchased another different brand and the same thing happened. when i go to the drive click on properties to check the drive it shows no info on it. so basically with 2 different usb's i was able to download the iso, but when installing bcd it installs the folder (labeled boot) then when trying to repeat the process by safely removing the device then plugging it back in and checking the drive to see whats on it, it gets corrupted all happening only after attempting to install bcd! anyone please help!

Microsoft windows vista
32 bit os