Cloned SSD not booting

#1
I have an Acer Aspire 5051 AWXMi laptop that failed to boot - the dreaded blue screen. It was running 32 bit Windows 7 Home Premium. I also have a smaller laptop running the same OS and decided to use cloning software from MiniTool and migrated the OS from the hard drive to an SSD - hoping to improve speed of the 5051. The SSD was connected to the small laptop with usb to IDE adapter, because the hard drive in the 5051 is an IDE not a sata drive. The migration appeared to be fine and all files including the OS were transfered to the SSD, but on placing the SSD into the 5051 it would not boot. From a trawl of the internet it appears to be a common problem, but I have failed to find a solution.

Some years ago I had obtained a Windows 7 Easy Recovery Disk from NeoSmart, so I installed the SSD in the 5051 and ran the ERD. I chose Automated Repair, but it comes up with the error in red print "Unable to find any valid Window partitions"

I selected the command line option and tried to use 'testdisk'. Not really sure how to use it, but I was able to cycle through the options for changing the status of the partitions. Partition 1 is listed as Smart System and Partition 2 contains the folders, files and Windows copied from the small laptop. I was able to change the status to *primary boot partition. I tried this for both partitions, but with no success - the SSD would not boot. Any ideas?
 

Terry60

Knows where his towel is.
Staff member
#2
A couple of potential problems.
a) The Partition Manager/command combination must say in the documentaion that it's designed to move OSs, a copy of all the files from one device to another won't suffice.
Assuming that's not your problem, cloning an OS from one PC to another is probably not going to work unless they are practically identical. OEM pre-installed OSs will contain only the driver set for the hardware and mobo chipsets of the donor device which are probably quite different to the recipient, especially if they're of different ages.
You can possibly check if that's the problem by installing the cloned SSD back in the donor laptop and seeing if it boots that one OK.
 
#3
Yes I had not thought about that. I have decided instead to try to do a clean re-install of Windows 7. I have an iso file on a usb flash drive. However, nothing is simple. When I boot the flash drive, the files load, I select the language, agree the licence terms and click Install. I select Custom for a clean install, but then with the appearance of the question "where to install Windows", nothing is displayed and there is an error message "No drivers were found. Click Load Drivers to provide a mass storage driver". Where am I supposed to get a driver from? I found a web site for acer aspire drivers, but it does not appear to be active.
 

Terry60

Knows where his towel is.
Staff member
#4
#5
Finally managed to get a working laptop, but with the old hard drive. You were right about the formatting. It kept comming up with no drive detected. I was using an unallocated partition. Once I had formated to ntfs and created a primary partition it worked fine. I will have to have another go with the ssd. According to the manufacturer it does not require a special driver, so it should work. I have not had much luck with the Easy Recovery Disk
 

mqudsi

Mostly Harmless
Staff member
#6
@eddieprice my guess is that your IDE-to-USB adapter is not supported by EasyRE. If you run EasyRE on the actual host using the standard IDE connector, it should pick it up fine.

Do you know what chipset the USB to IDE adapter uses? Maybe we can add the driver to EasyRE.