"Create a System Image" VHD to VM - How to Make It Bootable?

#1
"Create a System Image" VHD to VM - How to Make It Bootable?

Hello to the Neosmart forum - I'm posting a request for help here, that I've posted over at reboot -
Win7sp1_Ultimate_64bit - I used "Create a System Image" to make a .vhd of an existing install --
of course it produces a "WindowsImageBackup" Folder w/ multiple files several folders deep --

I renamed the main .vhd image file to " 7.1sysimage.vhd ",
then used the standard bcdedit cmd lines to make it Native Bootable:

bcdedit /copy {default} /d "V:\7.1sysimage.vhd"
... device vhd=[V:]\7.1sysimage.vhd
... osdevice vhd=[V:]\7.1sysimage.vhd

I also used the approach in MS KB 223188 How to restore the system/boot drive letter in Windows

so that Native Booting from the VHD will write to its own registry,
and not the existing install from which it was cloned --
"proved" by creating a file on the .vhd and not seeing it when booting back into the existing install.

So far, so good -- now, I realize that using "Create a System Image"
to make a VHD from an existing install is probably the lazy man's way,
but I plan to do it the "proper way" next,
by learning to use both imagex & DISM to do it.

But still, I'd like to learn something from this lazy man's approach --

so, when I try to boot this vhd from VirtualBox 4.2.18,
of course I get the error " FATAL: INT18: BOOT FAILURE ".

( When I use VMWare Standalone Converter to make a VM from this same existing install,
it runs fine in VirtualBox w/ the same settings (I/O APIC, SATA drive, etc) --
so I'm pretty sure it's because I've ONLY lifted the Boot partition, and not the SYSTEM partition,
from the Backup Image -- in other words, if I attach the V:\ 7.1sysimage.vhd,
there's no "Boot" folder, no "bootmgr" file, no "BOOTSECT.BAK" file. )

But wait - is this .vhd "Active" ? No .... so I attach it, then in Disk Mgmt, Rclick & set "Active".
Start it up again in VirtualBox, now get a more encouraging error :

A disk read error occurred
Press Ctrl+Alt+Del to restart

so ... I've read about some different commands to properly set the boot information, such as :

"bootsect.exe /NT60 F: /FORCE /MBR" , and
"bootrec.exe / fixmbr X:\ boot\ bootsect.exe / nt60 all / force"

but I'm just not clear on which command(s) to use,
or where to run them from,
or how to run them --

since I can't even boot the .vhd from the VM - should I attach it,
then \cd into it from a CMD line from the existing install?
and then run bootsect.exe or bootrec.exe from my WAIK install?

and also - when someone can help me understand WHAT to do,
will you also kindly help me understand exactly what the command(s) is doing?
-----------------------------------------------------------
Ok - I just tried this, with no change to the error message:

I attached the .vhd, then opened Deployment Tools CMD prompt,
& navigated to Tools\PETools\amd64 & ran the command;

bootsect /nt60 o: /force
Detached, then restarted VBox.
No change, same error message:

A disk read error occurred
Press Ctrl+Alt+Del to restart
-----------------------------------------------------------
Now, using 7zip I extracted bootrec.exe from a 64bit Recovery USB,
then ran the following at the Deployment Tools CMD prompt:

bootrec.exe o: /fixmbr
bootrec.exe o: /fixboot
bootrec.exe o: /rebuildbcd

but still no change - same error.