Created VHD image of physical Drive C: will not boot when attached via BCD menu with EasyBCD

BobxT

New Member
#1
Hi All,

I have created two images of my old Windows7 x86 drive C: each by way of different tools.

One was with M$ Sysinternals "Disk2VHD" and the other by "VMware vCenter Converter Standalone" and then converting the resulting .vmdk file to VHD by way of StarWind Converter Free.

Both resulting VHD files will boot when tested in the most recent VirtualBox under Windows 8.1 x64.

But neither VHD file will boot from the Win 8.1 BCD menu when added by EasyBCD.

I should note that I already have two bootable BCD entries, booting Windows 10 TP x64. Both of these boot perfectly. So, the problem is not the ability of EasyBCD to add correctly to the Win8.1 BCD menu and since both of the two problematic VHD's do boot in VirtualBox I cannot see there is any problem with EasyBCD.

I have used both EasyBCD 2.2 and the latest beta. No difference.

Can anyone tell me what is wrong please.

I tried in desperation: the 2 VHD's that will not boot, were re-created after the physical original Windows partition had the antivirus turned off and the page file set to NONE. Again no change.

I get a BSOD error 7B. This is the same physical computer and the drivers should all be suitable, not like I am using the VHD created from a totally different computer.

Regards,
BobxT
 

mqudsi

Mostly Harmless
Staff member
#2
This isn't a problem with the boot configuration or the VHD itself per-se, it's a problem with the contents of the VHD.

A BSOD with 0x7B indicates a problem accessing the boot device. By default, unless Windows 7 was installed to the VHD in the first place, Windows does not enable the VHD drivers during the boot process. VMware, et. al. use the VHD to virtualize what appears to the OS to be a physical SATA or SCSI disk, and as such, are not subject to this limitation.

You'll need to manually edit the registry and change the VHD driver to be boot-time enabled under HKLM\SYSTEM\CurrentControlSet\services
I don't know the name of the VHD driver off the top of my head. You'll need to change the value of "Start" to 0x0, which indicates that it is a boot-critical driver to be loaded before initializing the kernel.
 

BobxT

New Member
#3
This isn't a problem with the boot configuration or the VHD itself per-se, it's a problem with the contents of the VHD.

A BSOD with 0x7B indicates a problem accessing the boot device. By default, unless Windows 7 was installed to the VHD in the first place, Windows does not enable the VHD drivers during the boot process. VMware, et. al. use the VHD to virtualize what appears to the OS to be a physical SATA or SCSI disk, and as such, are not subject to this limitation.

You'll need to manually edit the registry and change the VHD driver to be boot-time enabled under HKLM\SYSTEM\CurrentControlSet\services
I don't know the name of the VHD driver off the top of my head. You'll need to change the value of "Start" to 0x0, which indicates that it is a boot-critical driver to be loaded before initializing the kernel.
You may be right, but not completely.

I fixed the problem with info from this site:-
Preparing Virtual Hard Disks for Boot
https://technet.microsoft.com/en-us/library/gg318056(v=ws.10).aspx

While I now have the imaged partition booting as a VHD file, I have also become aware of a bug in EasyBCD.
When I get time I will make another post on this other issue.

For now, my problem has been fixed completely and I can regard this issue as being closed. I hope this may aid anyone else in future.

Regards,
BobxT