Damaged my laptop boot using EasyBCD

So I thought I was fixing the boot record of a desktop that I am presently upgrading. I can deal with that later but the problem is that I screwed up the settings of my main computer - a Dell laptop. I thought I had used the "Select BCD Store" but did not.

So I have taken a third computer, loaded EasyBCD and I am now accessing it correctly. Here is what it reads...

There is one entry in the Windows bootloader.
Path: E:\Boot\BCD

Default: Microsoft Windows 7
Timeout: 10 seconds
EasyBCD Boot Device: E:\

Entry #1
Name: Microsoft Windows 7
BCD ID: {default}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

The E:\ is because I had to add a drive letter through computer management, to access the recovery partition and boot device.

I'm all out of ideas and feel desperately stupid - please help!!

I have a very old backup of the entire hard-drive - could I copy that Recovery partition to the new one?

ETA: Trying System Recovery Options shows a partition size of 0MB and an unknown location for windows...
Last edited:

Mak 2.0

Staff member
Well you cant just transfer the BCD from 1 PC to another. The UUID will not match, that meaning that the drive unique identifier will not match from system to system. So I dont know why you tried using EasyBCD on a 3rd system to fix a boot corruption on another one. It wont work out that way.

Do you have any install media for the Dell Laptop? You can try to use that to fix the boot issues on the laptop.
OK - the backup I have is a "Casper XP" backup - an image of the same hard-drive including all partitions. The recovery partition would be the same size.

I should have install media for the Dell laptop - but I don't think it includes SP1. I can try a repair on it, but the System Recovery DVD I just created gives me no joy whatsoever. From the command prompt it can't find the Windows OS installation and I think the damage may be permanent.

I thought that EasyBCD could be used to fix a damaged boot sequence for an offline hard-drive. Maybe I'm mistaken here.

Thanks - but I'm still not out of the woods yet.


Startup repair can't find the windows installation, yet I can see both partitions when I put the HD into an external enclosure. What have I done?


OK - idiot though I may be, I fixed it using diskpart, forcing it to find the windows installation, assigning drive letters to both of those partitions, making the C drive the right one, and re-writing the boot record.

Now attempting to do the same with the other (desktop) hard drive.