Dual boot Windows 10 and Server 2019

jkruby

Member
I just purchased EasyBCD. I have 2 bootable disks, one with Windows 10 and 1 with Windows Server 2019. Windows 10 was installed first on the C drive. Then I booted from USB and installed Server 2019 on the D drive. Once again they are separate SSD drives on separate SATA channels.

Wen both disks are in the PC it always boots to Windows Server. If I take the "server" drive out it boots to Windows 10.

I just started reading the EasyBCD documentation. There is no mention of newer versions of Windows!

Can I safely install EasyBCD on this configuration to allow Dual Boot at startup with Windows 10 as the default OS?

Right now the Windows 10 disk is in place and the PC is running. I can find no actual install information in the PDF.

So how do I do this? Install EasyBCD with Windows 10 running and then later add the Windows Server 2019 disk drive? And both OS options will automatically show up when I restart the system?

Thank you
 

Terry60

Telephone Sanitizer (2nd Class)
Staff member
Can you post two Disk Management screenshots, one with each OS booted.
Incidentally EasyBCD is free for home use.
It's not a boot manager, just a utility to help you manage the MS bootmgr BCD store easily, so you can install it when and where you like n complete safety.
It won't have any effect on your PC until you run it and ask it to add/change/delete something in the BCD.
Don't do that until I've had a look at your posted configuration(s) and can confirm what I assume is going on.
 

jkruby

Member
Hello Terry,
Thanks for responding. I was able to get the Boot Menu to finally show up.
1. I removed the "D" drive disk with Windows Server 2019 and booted to Win 10.
2. I installed the EasyBCD software.
3. Shut down the machine and re-installed the Win 2019 disk.
4. The Boot Menu did not show up.
5. Took the Win 2019 disk back out and booted to Win 10
6. Turned off the Fast-Boot option as mentioned in some forum posts.
7. Put the Win 2019 drive back in and Rebooted. Still no Boot Menu
8. Looked at the CMOS Startup options and saw that "UEFI boot order" was checked AND that somehow the Windows Server 2019 install-process had set the UEFI boot order so that SATA1 (the Win 2019 drive) would boot first!. I did NOT create that boot order.
9. Saw that the "Legacy Boot Order" was correct...USB, DVD, SATA0 (Win 10), SATA1 (Win 2019), SATA2 (Storage Drive).
10. UNCHECKED the "UEFI boot order" box.
11. Finally the Boot Menu shows up. I added the D Drive (Win 2019) to the menu and it works properly now.

I have attached screen shots.
Thanks again,

John Kotubyjohn-hp-cmos-uefi-settings.jpgjohn-hp-disk-mgmt.PNG
 
Top