Dual Boot Windows 7 and Fedora 20 does not work

#1
Hi

I had a working configuration of Windows 7 and Fedora 19.

When I installed Fedora 19 I did choose not to install a boot loader.

Then I booted into Windows 7 and ran EasyBCD 2.2 and added the following entry:

- Type: GRUB 2
- Name: Fedora 19
- Drive: Automatically locate and load

This worked fine. EasyBCD found the Fedora 19 installation and loaded the kernel.

Now I replaced my Linux Install with Fedora 20. (Same partitions used)

I did exactly the same as when installing Fedora 19 but it simply doesn't work. When I choose
the boot option "Fedora 20" some text flushes by and then I am dropped to the Grub menu

GRUB>

BTW, I also tried the following article and installed the GRUB Bootloader into the PBX (/dev/sda3).
http://nmilosev.svbtle.com/fedora-20-heisenbug-installation-tips-and-tricks

Without any luck. Boot process still ends with GRUB> prompt.

Any ideay why this worked with Fedora 19 but does not work with Fedora 20?

Regards,
Oliver
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#2
I think, you'll need to install 20 with the bootloader, just make sure it installs in the Linux partition, not overwrites W7's.
EasyBCD is trying to chain to the bootloader on the Linux OS.
 
#3
Hi thanks for the info.

1. Fedora 20 (19 as well) does not allow installation of Bootloader into Partition Boot Record. They claim that with GRUB 2 this is not supported behaviour.
2. You can do it anyway by dropping to the shell before rebooting after the installation finish.
You then type:

# chroot /mnt/sysimage
# grub2-install --force /dev/sda3 // in my case it is sda3 where Fedora 20 root (/) partition is (including /boot)
# grub2-mkconfig -o /boot/grub2/grub.cfg

So this has successfully set up GRUB2 inside the Fedora 20 root partition (not MBR).
Booting back to Windows 7 and using EasyBCD to add an entry as mentioned above (automatic locate GRUB2).

Doesn't help

EasyBCD Grub drops to GRUB> prompt instead of chainloading the Fedora 20 Boot loader.

Any ideas?

In Fedora 19 this worked.

Regards,
Oliver
 

Terry60

Knows where his towel is.
Staff member
#4
Sorry, you'll have to wait for someone with Linux knowledge more current than mine.
I stopped using it back at Ubuntu 10.something.
It has always been a problem for EasyBCD that various flavours of Linux choose to boot in widely differing ways, and change specs at the drop of a hat, necessitating a recode to accommodate the latest whim.
Sounds like Fedora 20 might have done something similar.
You might find more concentrated expertise on F20/EasyBCD problems on the Fedora site than here, where OS varieties are more catholic.
 
#5
Had the same problem...

You have to click "BCD Deployment", change dropdown to Windows Boot partition (C: or whatever)
make sure Vista/Win 7 radio button is selected

Then click "Write MBR"
 
#6
I had the same problem but forcing GRUB-2 to install on my Fedora drive worked for me. I have EasyBCD booting Android (GRUB-2), Mint Linux (Debian/GRUB), Slackware (LILO) and Fedora 20 (RedHat/GRUB-2) with no problems

The only thing I did differently when setting up Fedora boot in EasyBCD instead of choosing "Automatically Locate" I set it to the partition where my Fedora 20 (and forced GRUB-2 install) are located. Works like a charm!