Dual booting Windows 8 and Ubuntu 11.10 using EasyBCD

#1
I was having problems getting this to work. Most of the time, when I shut down Win 8 from the metro, the next time I started up, my PC would not display the boot menu and would go directly to Windows. To make matters worse, it would take several minutes for Windows to start. The only way to fix this was to hold the power button down after starting and starting again. This would result in the EasyBCD boot menu being displayed, and a much faster boot time into Windows. I have found that powering down Windows 8 by pushing the power button rather than selected Shut Down from the metro results in Windows being powered down (this must be selected in Power Options), and it seems to be faster. The next time I start, the boot menu is always displayed, and Windows loads quickly. It would seem that shutting down from the Win metro interface must do something different (hibernating in some way perhaps?) than pressing the power button.
 

mqudsi

Mostly Harmless
Staff member
#2
Where's the question here?
 

Terry60

Knows where his towel is.
Staff member
#3
#4
I disagree - even though the product does not appear to have a deffect, it was not being allowed to function correctly due to the arcitecture of Windows 8 (or so it seems). Other users may encounter the same problem and look to this board for a possible answer. That is the reason that I posted this resolution.

Concerning Computer Guru's response, not all postings have to be questions - they can be answers, or updates to a user's original posting suggested a solution.
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#5
I had no issue selecting Shut Down from the menu within Win8 and from there getting the Boot Loader options to allow me to boot into any other OS I had installed at that time. It has nothing to do with the architecture of Win8 at all cause for me it works as it should. For this to be a true resolution, it would have to be something that many people are experiencing and can duplicate with ease, meaning that it is truly a bug with the OS itself and not your specific setup.

Sounds like your install has some quirks and not Win8 itself.
 
#6
I thought I read the default for Win8 was hibernate using the power switch, but who knows.

I hated to do it, but I made a batch file and shortcut for my start menu screen so I could more quickly access power off in W8CP.

This is what I did;

1) Disabled all UAC (forever, thank you, but know the risks).
2) made a really simple batch file called shutdown.cmd with this code:
Code:
shutdown -s -t 00
(those are zeros)
3) put the batch file somewhere handy, like c:\Windows\batch (directory I created)
4) Opened Explorer, went to view put a check mark in the checkbox labeled File name extensions and Hidden items to show everything
5) used the run box to open; %AppData%\Microsoft\Windows\Start Menu\Programs
6) Created a shortcut to my batch file shutdown.cmd inside this start menu directory (I put it under Windows System), renamed the shortcut to shutdown
7) Right-clicked the shortcut, picked advanced, checked the box "Run as Administrator" apply, ok
8) At start screen, right click bottom, picked show all apps
9) From All Apps found my shortcut and right-clicked to "pin to Start Menu" or whatever.
10) My account has Administrator rights (not just normal user), so the thing works fine.

Quicker than the click the left corner, hover over the right, etc...

OR, one can just open up a run box and do the
Code:
shutdown -s -t 00
every time, lol.