EasyBCD 1.7 not generating nst_grub.mbr for Ubuntu Linux



I am using EasyBCD 1.7 to try to boot both Vista and Ubuntu Linux.
I have tried following this procedure:

Linux - NeoSmart Technologies Wiki

Although when I add a new entry in EasyBCD for my Linux partition the corresponding file C:\NST\nst_grub.mbr is not generated, even if the new entry appears correctly with this path.

I also tried creating a boot image manually by following this:
VistaGrub Prob - The NeoSmart Forums
So I used bootpart26 to extract my mbr, when I try to boot at start into Linux I receive an error message number 0xc000000f.

Has anyone bumped into the same issue by any chance?
So the points are (Grub already reinstalled into the Linux native partition):

1) EasyBCD is not generating the mbr file for Linux
2) Even when this is created via bootpart26, the boot fails

^ hello and welcome

i am kinda of dealing with the same issue however my easybcd created the nst_grub lol

We recived the same error, could you still not get on to linux?

CG will post here in a minute im sure he will be able to help us both! :smile:

My ubuntu thread
Last edited:
Hi mezz, welcome to NST!

Can you paste the output from "Debug Mode" (on the first page) here in a
Also, was GRUB installed to the MBR or the bootsector?
Thanks, here it is

Thank you for you help.
As I said I did follow the "Vista after Linux" procedure here:

Linux - NeoSmart Technologies Wiki

And I re-installed Grub to the boot sector of my partition. If I install it to the MBR I overwrite the Vista settings and I will lose Vista.



Windows Boot Manager
identifier {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device partition=\Device\HarddiskVolume1
description Windows Boot Manager
locale fr-FR
inherit {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default {c1467d7d-5ebe-11dc-bd3f-8c681ce02ec1}
displayorder {c1467d7d-5ebe-11dc-bd3f-8c681ce02ec1}
toolsdisplayorder {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout 10
Windows Boot Loader
identifier {c1467d7d-5ebe-11dc-bd3f-8c681ce02ec1}
device partition=C:
path \Windows\system32\winload.exe
description Microsoft Windows Vista
locale fr-FR
inherit {6efb52bf-1766-41db-a6b3-0ee5eff72bd7}
osdevice partition=C:
systemroot \Windows
resumeobject {c1467d7e-5ebe-11dc-bd3f-8c681ce02ec1}
nx OptIn
Real-mode Boot Sector
identifier {de9a6c81-5e80-11dc-ba2b-a25e1d30e2c1}
device boot
path \NST\nst_grub.mbr
description Ubuntu Linux
Last edited by a moderator:
OK, I see the cause.

Delete the EasyBCD Linux entry.
EasyBCD | Useful Utilities | Power Console
Type this in there:
bcdedit /set {bootmgr} device partition=c:

Then you shoud be able to safely add a Linux entry in EasyBCD without a problem.


I should point out that you need to turn EasyBCD off and back on after you execute the bcdedit command and before you add the Linux entry.
Last edited:
Thanks Computer Guru,

that fixed the file generation, although my boot still fails, point 2) of my original message.
The error status is: 0xc000000f, I have chosen the only Linux native partition on my drive and re-installed GRUB several times. Do you think you are able to point me in the right direction please?

Thank you
This is a BCD error, nothing yet to do with how GRUB was installed.

Leave the EasyBCD settings the way they are, but run this too from the Power Console:
bcdedit /set {de9a6c81-5e80-11dc-ba2b-a25e1d30e2c1} device partition=C:
Then reboot and check that out.