EasyBCD Error: 15 File Not Found

#1
I run windows 7 Pro on sda1. Second drive is sdb1. I have Ubuntu 10.13 on this drive (I can boot directly to this drive with no problem).
When I use Neogrub I get this message:
Booting command-list
Filesystem type is ntfs, partition type 0x07
kernel: /boot/vmlinuz-3.8.0-26-generic
root: uuid=1c9d1bde-4064-a8c2-c0bed38db2d1 ro quiet splash $vt_handoff
error: 15 file not found
Press any key to continue...

When I run Linux/BSD I get this message:

no such device: f99d472e-e65c-40e2-a753-34e612da2457

I can boot directly to Ubuntu by changing the BIOS drive order.

Can any one help here and tell me what this means.
 

mqudsi

Mostly Harmless
Staff member
#2
What is your NeoGrub configuration and how did you come by it?
 
#3
Some how EasyBCD is looking at the wrong UUID number. it should be 03f951dd-9145-42aa-91d1-af1f08f8384e. Is there any way to fix this without reformatting the second drive. It boots Win7 first then Ubuntu second. Is this what your asking for. If I change the UUID number in Linux/BSD it will boot to the proper distro.