EASYBCD won't download

When I click on the Download button, I see "Waiting for" and the website name flash down in the status bar, it takes me to the Thanks for Downloading page, but no download. I've got my settings set to ask for location and that never appears. Pop-up Blocker is turned off for the site. And I checked my download history. No EasyBCD. Quicktime update is there so I don't have a problem downloading. But not EasyBCD. What's going on and why can't I download the free version?
Last edited:

Mak 2.0

Staff member

You went to this page. Clicked the download button below the 2 input boxes and nothing happened? Have you tried a different browser? I just was able to download it in Chrome, Canary and IE10 just fine with this method.
Yep. Tried IE 9 and Chrome. I don't trust IE 9 since it's this is my office laptop and they may have tweaked IE 9 with "corporate permissions". But I've been able to download other stuff with Chrome (the aforementioned quicktime update). I just tried it again and this time caught a "Request sent" message in the status bar, thought they might have emailed me a download link, but no, still no download. Tried clicking the download button with Ctrl pressed to bypass any stealth pop-up blocker. But I just checked settings on Chrome and I've got pop-up blocker completely off. :x


Knows where his towel is.
Staff member
If it's your work PC, are you sure that they haven't set the Group Policy Editor to prohibit executable file downloads to prevent malware infections ?
Can you download other .exe files ?
It works instantly here, using Maxthon 3.
I just checked that and couldn't find anything that look like it was blocking stuff. I'm downloading another exe file that's an installer but not for an executable program. I'm not sure if it could tell the difference. I'll try another browser.


I think you're right. It blocked both Maxthon and Firefox. I don't dare upgrade to IE10 because there could be compatibility issues at the office. Is there a zip file of easybcd somewhere?


Ok - I outsmarted it. AirDroid to the rescue. I'll post my next question under a different topic. Thanks everybody.