EasyBCD writes menu files to C drive, not the USB i am working on/selected!!?


New Member
Hi all,

Ok - first - I have used EasyBCD quite a few times - select USB BCD store - do my thing and test USB.
I make menus and then test the USB on another PC to see if they work ok etc.
And I ALWAYS first select the USB drive's BCD store to work in/from.
Normally then the NST and ang0/1/etc files are written to the root of the USB in question.

BUT today suddenly the NST and ang files are written only to the C drive root???
I have selected the USB - tried a few - all menu changes are written to C drive only!! ( USB today are I and J and K drives )
Needless to say the USB wont boot or work without these files. :|

Only difference today is a i tried a Kingston Datatraveller Workspace 64GB USB - one of the new type that are seen as a fixed drive (but is a USB flash drive)
I was still setting the menu when it "disappeared" - no drive letter, and 10 min later i found it with windows disk manager - said "uninitialized" suddenlY? Was it EasyBCD throwing a fit? Or plain coincidence - dunno. :S
So I used my other regular USB's to work with - Apacer, Adata, Crucial, etc.
They all have this missing menu files cause they are on C drive error today (for the ones i worked on today)

Thing is i need to repair of fix my menu files to be saved to the selected BCD store device!! :lup:
Any ideas? What reg entry or file do i need to get rid off? Even tried reinstalling.
Rebooted a few times.

Last edited:


Mostly Harmless
Staff member
As you said yourself, it needs to be recognized as a removable drive for EasyBCD to store the boot files on it.

bcdedit corrupts external drives under certain cases. EasyBCD takes precautions to prevent that for drives that it detects as external (again, same cause).