Error message upon launching Easy BCD

#1
Hi everyone,

I recently tried to launch Easy BCD and I got this error Message. I tried to uninstall/install
and ended up with the same result.


Can you help.
Thanks.
 

Terry60

Knows where his towel is.
Staff member
#2
It's telling you that the BCD is not located on the first HDD in the BIOS boot sequence.
You can just say yes and tell it where your BCD is located.
 
#3
Thanks Terry but it's not the right answer.But it's not a wrong answer either.
Yesterday, when I opened Easy BCD, this error message did not show up.I launched it many times since then and it still works flawlessly.
Thanks anyhow!:wink:
 

Terry60

Knows where his towel is.
Staff member
#4
If you located the BCD manually, it will remember on subsequent starts.
See EasyBCD > Tools > Options > "Always load......"
 

Terry60

Knows where his towel is.
Staff member
#6
Normally there is only one BCD.
Normally EasyBCD will find it automatically. (if it's on the aforementioned active partition of the highest priority BIOS boot drive)
If you've contrived to configure your system so that it's elsewhere and then steered EasyBCD to it manually, it will continue to find it there.
If changes you make are reflected in the boot menu, then you're using the right one.
It would be unusual (though not impossible) to have multiple BCDs. You would have to have deliberately set out to create such a situation. Then it would be up to you which one you wished to be "in charge" of a multi-boot (and hence select with EasyBCD)
 
#8
Today, I still have this error message.I did not do anything to my computer since the date of my first post.
There's something here that I don't understand.
 

Terry60

Knows where his towel is.
Staff member
#9
Post a screenshot of Disk Management and copy/paste the "view settings" from EasyBCD
 
#10
Hi,
Today, Easy BCD opened flawlessly.Here again,I did not do nothing to cure it.
Her's a copy/paste of the view settings:
There are a total of 3 entries listed in the bootloader.
Default: Windows 7
Timeout: 30 seconds
EasyBCD Boot Device: Z:\
Entry #1
Name: Windows 8.1
BCD ID: {aa4361da-ac7d-11e3-8395-0021978fb715}
Drive: H:\
Bootloader Path: \Windows\system32\winload.exe
Entry #2
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #3
Name: EaseUS Todo Backup Linux
BCD ID: {c4b69194-4d16-d3ec-a98f-ea816ab385e9}
Device: \Device\HarddiskVolume5
Bootloader Path: \ESLOADLX
And my Disk Management screenshot:
 

Terry60

Knows where his towel is.
Staff member
#11
You appear to be looking at the wrong BCD. Somehow you have got a copy on your backup drive, and that's the (inactive) one EasyBCD is looking at. You should be able to confirm this by altering something cosmetic like changing Name = Windows 8.1 to Windows 8. When you next boot, the menu won't reflect your change, because that's not the BCD being used to boot the system.
EasyBCD is telling you that the boot files are on Z, but Disk Management shows that the system booted from the Boot Partition.
Disk Management flags have the following meanings "boot" = "this is the system you're running"
"system" = "this is where I found the boot files for the currently running system"
"active" (on the first HDD in the BIOS boot sequence) = "this is where I started the search for the boot files"
"active" (on subsequent HDDs in the BIOS boot sequence) ="this is where I will look if I don't find something in the MBR on the first HDD"

Since you don't have a letter on the Boot partition, you cannot navigate to it through the Explorer dialog in your OP, but you should be able to useEasyBCD > File > "Load System BCD store" to start using the correct one.
 
Last edited:
#12
There's something wrong there.
Z is an external backup drive non bootable.
Next time I have a problem with this software , I'll try File > "Load System BCD store" .
Right?
Thanks.