Every time I run easybcd it tells me the opening BCD registry error

#1
Hi, my laptop had some hard drive problems and it couldn't boot windows so I backed up the partitions and deleted them and installed a fresh win7 64 bit, but after the install win7 wouldn't boot at all, I used another laptop to get a mix of the win7 recovery iso and easybcd to create a bootable media, after that I was able to enter win7 and complete the installation. after I got to win7 I installed easy bcd, it asked me to manually find a .bcd file. I found the neosmart.bcd file in profiles folder and I added the win7 entry because there was nothing there. after a reboot I got the ctrl+alt+delete in boot, I used the flash memory to enter windows like before and I opened easybcd it asked me to find .bcd file. everytime I exit easybcd it askes for .bcd file next time and I think this is the reason I can't boot my windows without the help of flash memory. how can I make the neosmart.bcd recognized as the default settings for easybcd? thanks in advance
 

Terry60

Knows where his towel is.
Staff member
#2
The BCD does not belong to Neosmart. It's in the \boot folder in the root of the partition marked as "system" in Disk Management, and EasyBCD will locate it automatically if that partition is "active" (and it exists).
If you are unable to boot without the installation media, then I would guess you've got the wrong partition set "active".
W7 normally creates a unlettered partition called "System Reserved" where it keeps all the boot files unless you take steps to prevent it from doing so. That should be "active" otherwise the MBR (and EasyBCD) will be unable to locate the boot files.
 

mqudsi

Mostly Harmless
Staff member
#3
Do NOT open C:\Program Files\NeoSmart Technologies\EasyBCD\Profiles\NeoSmart.bcd

It's nothing to do with your PC and should not be touched. Do what Terry says.