Gettin the oxc ....001 error on dual boot

Discussion in 'EasyBCD Support' started by ECD2, Oct 14, 2017.

  1. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    I am doing a UEFI dual boot of two Windows 7 versions on separate drives.
    It was all working fine until I had to re-partition one of the drives to move future Linux partitions to a separate disk drive from the Windows 7 drives.
    I have now taken care of the partitions and I have two drives that will boot separately without issue.
    I have used EasyBCD to set them up for a dual boot.
    That went fine and gave me the dual boot menu.
    When I select Drive 0 from the menu, it boots without issue.
    When I select Drive 1 from the menu, I get the 0xc ....001 error that winload.efi is missing or corrupt.
    Here is my boot information.

    upload_2017-10-14_15-42-30.png

    I have tried a number of fixes ( repair disk / rebuildbcd), but nothing seems to work.
    Any suggestions you might have would be greatly appreciated.
     
  2. Terry60

    Terry60 Knows where his towel is. Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    10,238
    Likes Received:
    60
    Trophy Points:
    48
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    When you boot C, is it still seeing the other W7 partition as E in Explorer ?
     
  3. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    Yes, it is still showing as partition E:.

    I tried a bootrec /rebuildbcd and /scanos, but one of them said "the requested system device cannot be identified due to multiple indistinguishable devices potentially matching the identification criteria". I don't remember which one gave the error. I tried slightly changing the Guid on drive one, but it didn't change the boot problem.
     
  4. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    More Info: My drive 1 boot is now drive D: since I have moved a virtual drive to a higher letter.
    I am attaching a copy of the firmware in hopes that it provides additional detail that is helpful.
    upload_2017-10-17_10-22-55.png
     
  5. Terry60

    Terry60 Knows where his towel is. Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    10,238
    Likes Received:
    60
    Trophy Points:
    48
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Try deleting the BCD entry for the CAD system and adding it again, pointing it to whatever letter that OS currently resides on according to Explorer on the running OS.
    Deleting Menu Entries
    Adding Entries
     
  6. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    I deleted the Autocad entry in the menu and saved it.
    I added it again and saved it.
    I rebooted and still the same result.

    I presume that those steps delete c:\boot\bcd and create a new one?
    When I do a detail partition on C: and D: they both have the same type (xxxxxx} identifer.
    Is that a problem?
     
  7. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    I have done some more research in trying to figure this out. It looks like that it is using Volume 5 to boot. No sure why the volumes are numbered the way they are. Here is a snapshot of the mapping:
    upload_2017-10-17_16-29-45.png
    If this numbering sequence is not relevant to the booting problem, please let me know.
     
  8. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    Oops! I rechecked what I thought I had found. I looked at the BCD again with my hex editor and found that it is looking to Volume 7, not Volume 5 when it first boots.
    It reads "Device\Harddisk Volume 7 \ boot\bcd" in the first few bytes of the BCD.

    I guess I am somewhat confused. I know the bios looks to the Fat partition (either V5 or V2) and then it should point to either V7 or V4 to load windows.
    I will stop for now and await more information.
    Thanks for your assistance.
     
  9. Terry60

    Terry60 Knows where his towel is. Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    10,238
    Likes Received:
    60
    Trophy Points:
    48
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    No, deleting or adding an entry to the BCD don't remove the whole BCD and replace it, just change the contents as the names suggest.
    Can we start from scratch.
    Please post the contents of EasyBCD "view settings" and a screenshot of your Disk Management (The MS version - Admin Tools > Computer Mgmt > Disk Mgmt) showing all of the partition status flags.
     
  10. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    upload_2017-10-19_19-21-0.png

    upload_2017-10-19_19-21-17.png

    Here they are.
     
  11. Terry60

    Terry60 Knows where his towel is. Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    10,238
    Likes Received:
    60
    Trophy Points:
    48
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Well, that looks to be OK, with one proviso.
    I note that you have two EFI system partitions because you either installed the OSs independently or you've cloned one from the other.
    It's possible that the EFI partition you're booting from, is not the same one that you're looking at (and updating) with EasyBCD.
    i.e. any changes you make are not having the slightest effect on the way the system boots.
    For MBR boots, I'd advise you to look in Tools > Options and make sure you're not telling it to load the wrong BCD, but I'm not sure what that will look like on a two-EFI PC (unique in my experience).
    You could try File > Load system BCD and see if that works on a twin EFI system or see what navigation options it comes up with using File > Select BCD store.
    Failing that, disconnect the CAD drive and boot the main OS alone, look in the BCD and see if it looks the same as above.
    If it doesn't then you've been changing the wrong one, hence no joy.
     
  12. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    Thank you for the suggestions.
    I tried the File> Select store option and it appeared to open on the C: drive, although it might have opened at the lowest drive letter by default. Not knowing which, this was inconclusive.
    I did the File > LoadBCD, but no visible results.
    It looks like from my above shapshots that we have some definite clues that indicate I am not booting from the right partition.
    From above snapshot:
    upload_2017-10-21_16-21-57.png

    Boot Manager was booting using Harddiskvolume2, which is the FAT32 partition on the Autocad disk.
    I had to use the AOEMI partition assistant and look at the properties of each partition to see how the Harddisskvolumes were numbered ( the snapshot is above).
    It appears that my add-in SATA card is getting numbered before the SATA ports on the MB.
    I disconnected the Autocad drive and rebooted.
    The boot menu still showed the two options.
    With booting from the Windows 7- Main disk, I did not get the Harddiskvolume2 in the boot manager.
    I saved the settings and shut down.
    I reconnected the Autocad drive and booted, but no change in behavior.

    This document helps explain the case when you have multiple versions of Windows in use:
    BCD System Store Settings for UEFI
    However, if BitLocker is enabled or a computer has multiple installed versions of Windows, osdevice and device might be set to different partitions. BCD-template sets both elements to drive C, which is the typical value. You can also explicitly set the osdevice and device values, as shown in the following example. The example also assumes that you have specified the Windows boot loader for EFI as the default boot-loader object.
    Bcdedit /set {default} device partition=c:
    Bcdedit /set {default} osdevice partition=c:
    So with multiple versions of Windows, it is necessary to specify the FAT32 partition for Windows Boot Manager to use. That is what is shown in my snapshot with the red arrow above. I changed mine to boot from Harddiskvolume4 which is the FAT32 partition on my Windows 7 – Main drive.
    Follow the script for Device Setting from the above document.
    Bcdedit /set {bootmgr} device partition=s:// system partition
    In my case is had to omit the “// system partition” for the Bcdedit command to work.

    I can now verify that when I boot to either drive, the system remains as Harddiskvolume4 for both boots.
    I feel like I have made it to third base so far!
    When I say that I can boot to either drive, things are not quite right yet.

    When I do the normal boot, I get the oxc 00034 error. If I hit enter, then it gives me the 0xc 000f error. If I hit enter again, I get to the Boot Mgr. Menu. I can then boot from either selection normally.

    In an attempt to resolve this problem I did a “Remove Duplicate Firmware Object in BCD and NVRAM” from this Microsoft document:
    Remove Duplicate Firmware Objects in BCD and NVRAM
    I did a reboot and the Boot Mgr. Menu came up normally. So that problem is fixed.

    When I booted to the Windows 7 – Main option, it booted normally.
    When I booted to the Windows 7 – Autocad option, I received oxc 000e error.
    Progress, but not quite a home run!

    If this were single boot, I would rebuild the bcd and that would normally fix it. Since this is a dual boot system, I will get the “duplicate ids” issue mentioned in the following article: Issue with a Windows 7 Boot issue - involving the BCD perhaps

    I tried the doing the modification on the Autocad partition so that it does not show up as a system drive. Had to rebuild the bcd and the boot firmware and I end up back at the same oxc 000e error.

    Sorry this post is so long, but maybe it will help someone else who has this problem.

    Here is the current state of the Bcd:
    upload_2017-10-21_16-30-29.png
    Any suggestion would be appreciated. Thank you.
     
  13. ECD2

    ECD2 New Member

    Joined:
    Jun 9, 2017
    Messages:
    12
    Likes Received:
    1
    Trophy Points:
    1
    I am very pleased to report that I have resolved the problem and now my dual boot works properly.

    As I mentioned above I was running the two drives off of different SATA controllers, one on the MB and one on a PCIe SATA expansion card.

    Since my PCIe SATA card has four ports and the MB only two, I put both of the drives on the PCIe SATA card. I rebooted into each without issue. Each of the boots did give me the small Windows restart notice. I restarted on both of them and all is well!

    I checked by BCD and it now shows HarddiskVolume1 under the windows boot manager.

    Looks like my firmware had a problem with the separate boots being on different controllers.

    I have been to hell and back a few time with this, but I kept at it. I have moved up the learning curve a little, so I don't panic when I get oxc errors anymore.

    Many thanks to Terry for his assistance.
     
    Ex_Brit likes this.
  14. Terry60

    Terry60 Knows where his towel is. Staff Member

    Joined:
    Nov 9, 2007
    Messages:
    10,238
    Likes Received:
    60
    Trophy Points:
    48
    Occupation:
    Retired System Programmer
    Location:
    Wiltshire, England
    Searching online, it seems that whilst rare (not seen by me in this forum before), the existence of multiple EFI System partitions is not unique to you and generally seems to confuse the hell out of the boot-time firmware.
    Like most obscure software bugs of my former professional acquaintance, they often seem to arise when the end-user does something the designer/author never even considered when coding.
     

Share This Page