Gray screen after rebooting from kali

AK2H

New Member
#1
Hi there,
I successfully dual booted Windows 10 and Kali linux by using EasyBCD.

However in most tutorials using EasyBCD they used to select "GRUB 2" in the type box
But this didn't work for me
After many hours of searching I figured out I should use "SysLinux" instead and it worked!

(Dunno if this matter but I used a separate Partition for /boot and let the GRUB boot menu be installed on it during the Kali Linux installation setup,
and selected the boot partition in the drive box in EasyBCD )

My Problem is that after I boot to Kali (from the new boot menu created by EasyBCD) Everything works fine in the system but when I shut down the system and try to power on the computer it get stuck before showing the boot menu showing me a grayed out screen instead.
I managed to fix this by entering the bios and disabling Fastboot option.

I Repeated the boot steps to make sure its fixed for good but the same thing happed after booting to Kali and shutting down
So somehow the Fastboot isn't the reason behind the problem, BUT toggling it on and off will fix the problem for some reasons.
Any Ideas how to fix it ?
 

AK2H

New Member
#2
I was able to fix it by using "GRUB (Legacy)" instead of GRUB 2 or SysLinux.
I don't why it's not mentioned in any tutorial that we can use the old "GRUB (Legacy)"
And by the way this option is much better because when you choose Kali Linux in EasyBCD boot menu it get you directly to the GRUB menu
Where as in SysLinux it will shutdown and boot again to finally reach the GRUB menu
 
Last edited:

Ex_Brit

If you're going through hell, keep going
Staff member
#3
Glad you sorted it out. I'll ask the owner to comment.
 

mqudsi

Mostly Harmless
Staff member
#4
That's odd because I don't think Kali has used legacy GRUB in a while. However, depending on the ancillary settings you specified in EasyBCD when adding the entry, you could be using one of the special "auto detection" modes where EasyBCD does all the heavy lifting.

In all cases, I'm glad you got it working the way you want.