Hi Guys, can you work your magic again for me: Samsung Omnia i900 Wi-Fi set-up!

six-h

New Member
#1
First of all, Pleased to report that my home network that you helped me set up, is still performing well!
Thank you for helping me get it that way!!

Latest conundrum is that I've been given a "Smart Phone"...well, it's smarter than I am!(Doesn't take much!)

It has eaten up all my spare time since early December trying but failing miserably to get it to connect to my Speedtouch 585v6 Router.

The only minor success I seem to have had at some point is that the router now has the phone's Mac address listed on it's "Devices" page, but as an "Unknown" device, and has assigned an "etherport" icon to it.
the details page shows that it has the same IP address as my PC's Network Adapter card, and that it is "static" and "inactive".

The phone has nine Network Adapters listed, and combining these with the many, many other Wi-Fi related settings, I seriously doubt I'll live long enough to try all permutations!


Does anyone have this beast, or a similar device running Windows Mobile 6.1 ??

I'm praying for simple step by step instructions:lol:
 

JustinW

Super Moderator
Staff member
#2
Windows Mobile doesn't run on an iPhone, plain and simple...

As for your router you don't have a DHCP server setup to hand out IP addresses to your devices. Look through the settings and it should be one of the pages. Check your computer's TCP/IP properties in network connections in control panel or network sharing center to make sure it'll get an address from your router automatically rather than using a static one..
 

six-h

New Member
#3
Hi Justin,
Where did the iPhone reference come from, I'm struggling with a Samsung Omnia i900!:lol:
As for your router you don't have a DHCP server setup to hand out IP addresses to your devices. Look through the settings and it should be one of the pages. Check your computer's TCP/IP properties in network connections in control panel or network sharing center to make sure it'll get an address from your router automatically rather than using a static one..
I don't understand any of this, looked in Network Sharing > Properties but don't understand what I see!
Furthermore, I'm scared of messing up my nicely performing network.
I thought that the phone (being Wi-Fi capable) would just connect, like my laptop did:frowning:


Addendum:

Just a little more information that might help, I'm using Vista Ultimate on my PC, and the motherboard is an Asus P5Q3 Deluxe/WIFI-AP @n
Here is the "IP /config" report which mentions that DHCP is enabled.
Does that help?
Microsoft Windows [Version 6.0.6001]
Copyright (c) 2006 Microsoft Corporation. All rights reserved.

C:\Users\admin>IPconfig /all
Windows IP Configuration
Host Name . . . . . . . . . . . . : GEOFF-PC1
Primary Dns Suffix . . . . . . . :
Node Type . . . . . . . . . . . . : Hybrid
IP Routing Enabled. . . . . . . . : No
WINS Proxy Enabled. . . . . . . . : No
DNS Suffix Search List. . . . . . : lan
Wireless LAN adapter Wireless Network Connection:
Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : 802.11n Network Adapter
Physical Address. . . . . . . . . : 00-15-AF-86-DA-31
DHCP Enabled. . . . . . . . . . . : Yes
Autoconfiguration Enabled . . . . : Yes
IPv4 Address. . . . . . . . . . . : 192.168.1.73(Preferred)
Subnet Mask . . . . . . . . . . . : 255.255.255.0
Lease Obtained. . . . . . . . . . : 29 December 2009 21:15:15
Lease Expires . . . . . . . . . . : 30 December 2009 21:15:09
Default Gateway . . . . . . . . . : 192.168.1.254
DHCP Server . . . . . . . . . . . : 192.168.1.254
DNS Servers . . . . . . . . . . . : 192.168.1.254
NetBIOS over Tcpip. . . . . . . . : Enabled
Tunnel adapter Local Area Connection* 6:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . : lan
Description . . . . . . . . . . . : isatap.lan
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 7:
Media State . . . . . . . . . . . : Media disconnected
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : 6TO4 Adapter
Physical Address. . . . . . . . . : 00-00-00-00-00-00-00-E0
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
Tunnel adapter Local Area Connection* 10:
Connection-specific DNS Suffix . :
Description . . . . . . . . . . . : Teredo Tunneling Pseudo-Interface
Physical Address. . . . . . . . . : 02-00-54-55-4E-01
DHCP Enabled. . . . . . . . . . . : No
Autoconfiguration Enabled . . . . : Yes
IPv6 Address. . . . . . . . . . . : 2001:0:d5c7:a2d6:3c24:27ce:3f57:feb6(Pref
erred)
Link-local IPv6 Address . . . . . : fe80::3c24:27ce:3f57:feb6%11(Preferred)
Default Gateway . . . . . . . . . : ::
NetBIOS over Tcpip. . . . . . . . : Disabled
C:\Users\admin>
 
Last edited:

JustinW

Super Moderator
Staff member
#4
Aw, I misread it :lol:

Ok, so your DHCP servers working. So if your computer is getting an address automatically it must be the phone. I would check every possible page for the addressing method to see if a static address on it is set. Once you're sure its automatic like the computer sometimes the best you can do is reboot everything, including the router so fresh addresses are handed out.
 

six-h

New Member
#5
The only pages on the phone that seem to list addressing methods are the nine network adapters.
The list reads:-
SyChip Jaguar WLAN GSPI Card
NE2000 Compatible Ethernet Driver
AsynMac NDISWAN Miniport
Bluetooth PAN Driver
Remote-NDIS Host
Virtual Ethernet Intermediate Miniport
PPTP NDISWAN Miniport
L2TP NDISWAN Miniport
Mocrosoft null Ethernet Miniport Driver

Each of these has the option to use server assigned or specific IP addresses.
I had set them all to "Specific" entering the IP, Subnet and Default Gateway settings shown on the PC's wireless network details posted above.

The phone always seems to revert to the "Bluetooth PAN Driver" for some reason, however I feel (rightly or wrongly) that the one to use is the "SyChip Jaguar WLAN GSPI Card" since it's the only one that when I change the IP address back to "Server assigned", does not show "Disconected" like all the others.

It shows the following IP address which does not change, but looks strange : - "fe80::213:e0ff:fef9" (the first seperator is not a typo, it is infact showing two colons)

Still unable to obtain a connection with it.:huh:
 

six-h

New Member
#7
Hi Justin,
When you say "Set 'em all to Auto" I presume you mean the "Server Assigned" option.
As I say, doing that results in all except the "SyChip Jaguar" adapter saying "Not Connected".
"SyChip Jaguar" at least shows an IP address...if that is what it is, it looks strange!

Persevering regardless, I've tried each adapter using the "Server Assigned" option in spite of the "Not Connected" and the "Funny" looking IP address that result from that selection, but the result is the same:frowning:
 

six-h

New Member
#9
"fe80::213:e0ff:fef9" (the first seperator is not a typo, it is infact showing two colons)
 

JustinW

Super Moderator
Staff member
#10
Well that's the ID for the device (its MAC address), but you need an IP address to reach the internet.
Again, have you tried restarting everything? Turn off all the networked devices and reboot the router. Than power each one up at a time and verify its connected/has internet access.
 

six-h

New Member
#11
Hi Justin,
No, it's not it's Mac address, that is : -
For the Wi-Fi : 00 13 E0 F9 B0 80
And for the Bluetooth : 00 21 D2 F9 83 EB.

I don't know what fe80::213:e0ff:fef9 is, it's certainly strange with the two colons, but I can't alter it since it's provided as soon as I select "use server assigned IP address".
Re-booting the router won't affect that will it?
 

JustinW

Super Moderator
Staff member
#12
What's the router we're dealing with? Is your network secure (requires a password)? Some routers (like mine) well lock out devices that have failed authentication even if once and the only way to fix that is to reboot.
 

six-h

New Member
#13
Hi Justin,
My router is a Thompson Speedtouch 585v6.
It's set up to automatically accept new devices, with WPA-PSK and TKIP.
I've entered this detail into the phone along with the Network Key, but it never gets past "Connecting".
 

JustinW

Super Moderator
Staff member
#14
Ok, did you manually type in the network ID into the phone? Its probably better to have the phone search for available networks and than supply the key when prompted. This also makes it where you don't need to know the encryption type. You may need to reboot the router before it accepts connection with your phone.
 

six-h

New Member
#15
Hi again Justin,
No, the network automatically appeared at the top of the list as "available".
I just entered the required network key.
Occasionally it makes me enter all the details by hand, but mostly it remembers it all.
I'll try re-booting the router when I get the time and see if that makes any difference!