How to change Win7 loader in Ubuntu10.04/Win7 setup?

#1
In summary, my hard drive looks like this:

partition 1 - used for Linux
partition 2 - Win7 loader
partition 3 - Win7 itself
... other (logical) partitions for Ubuntu usage

I should like to boot Win7 from partition 3, in order to free partition 2, not because of its present size, but because I could use another partition id for more useful purposes.

I was advised, in Ubuntu forums, that easyBCD was the tool to do it, so I downloaded (also donated, by the way, because free software does cost a lot of money), launched it, but saw no obvious way to do what I need non-disruptively.

Would some kind soul give me some advice? Thank you in advance
 

Terry60

Knows where his towel is.
Staff member
#2
BCD Backup/Repair
Change Boot Drive
Point it to the W7 partition letter (probably C ?) when it asks.
That will copy all the boot files to the W7 partition and set it active.
When you reboot, you should find C is "active" "system" "boot" and the other partition is free for format.
 
#3
I did as Terry60 suggested, but unfortunately (for me) the process was anything but non-disruptive. Win7 must have overwritten the MBR and now I do not have access to the Linux partitions. I went back into easyBCD and tried to have it install Grub2 and configure it (automatically, as it claims to do). But when I reboot I get a screen where, besides Windows, I get two other options (Neogrub bootloader and Neosmart Linux) which lead nowhere but to "try (hd0,0): ext2", which is not even grub2 terminology. What a mess!

Any suggestion?
 

Terry60

Knows where his towel is.
Staff member
#4
Sorry, you didn't say that you were booting via grub, not W7.
The W7 boot files should now have been copied across. If you want to put grub back in charge, reinstall grub2 to the MBR and it should find W7 on the C disk.
Your problem with adding a grub2 linux entry has been reported before
http://neosmart.net/forums/showthread.php?t=7056
but I don't think CG has been able to reproduce it to find a fix.
Normally it works straight out of the box.
I'll draw his attention to this thread, in case he'd like you to try something (and you'd be willing to help debug the problem)
He's currently working on converting Neogrub from grub4dos to grub2, having managed to get it compiled under Windows.
(that non-grub2 message is from Neogrub which is acting as a bridge between bootmgr and Linux)
 
Last edited:
#5
Thank you, Terry. I have solved the problem by booting from an Ubuntu LiveCD, installing Grub2 to the hard drive, rebooting from the hard drive, updating Grub2; I now have Win7 and Linuxes booting as originally intended. As an aside, I think EasyBCD may be recommended to Windows users, but maybe not to Linux users like me.
 

mqudsi

Mostly Harmless
Staff member
#6
This is fixed in the next beta build of 2.0.3