HP Vista Crash

#1
Well my Vista took a dive the other day, it tried to repair itself or rather the HP utility did. I did not continue as it wanted to go back to initial settings and I did not have a good back up of all my recent data.

I purchased the NeoSmart Vista recovery, burnt it and booted the HP up. I was following the step by step here:

http://neosmart.net/wiki/display/EBCD/Recovering+the+Windows+Bootloader+from+the+DVD

but my windows did not look the same, not sure if I d/l'ed the correct file. I did by it in order to complete the d/l. It says windows recovery essentials and I have 5 options :
AUTO REPAR
Partition editor
browse/back up files
intrernet browser
launch command line

The only thing that really worked was the first so I did do a auto repair but now it boots up and says that:

file:\windows\system32\winload.exe
error code 0xc000000f
is missing or contains errors.....

any advise?

I hope that I did the correct partition repair as it give me a few choices,
data volume 103 gig, active no
windows Vista 32 active yes
data volume 2 gig active no

all 3 are NTFS all I can do is a auto repair or a system restore, dont want to lose my data......


thanks in advance

Addendum

update:

http://neosmart.net/wiki/display/EasyRE/System+Restore

my Hp has the same screens as the above link, OK so my question is do I dare do a restore and risk losing data or is there some way I can do a recent save before restoring? Still not sure why I have the 3 partitions above. Also I do a have a usb HD that has stuff on it but no sure it it has a current restore point. Of course my XP machine can read the usb drive when I plug it in to look at it, it only works on vista that is the dead machine.
 

Terry60

Knows where his towel is.
Staff member
#2
#3
I looked at the back up option but it does not see my HD, the only data that appears is the bootable CD-ROM.


any advise on the winloader.exe? I cant copy the file onto the HD somehow?
 

Terry60

Knows where his towel is.
Staff member
#4
When they say "is missing", it's very unlikely that it's anything to do with Winload itself.
That's just the first link in the boot chain on that drive, so if the drive is missing/corrupt, it will be unable to find Winload (or anything else), but it hasn't got as far as looking for anything beyond the bootloader yet.
Does the Linux partition editor show your Vista partition ? Does it say it's NTFS ?
If you're not familiar with navigating Linux, you can get a free bootable partition manager which will show you the contents of your HDD.
If the Vista partition doesn't appear by the label you gave it (if you gave it one when you formatted), or shows as RAW instead of NTFS, then it's likely your MBR partition table is corrupted and you may be able to repair it with Testdisk and subsequently save your personal files before you "factory reset"
 
#5
update: the Ubuntu disk is loaded up but it does not see the correct partition on my HD. I can see one but there is nothing on it.

Terry, I will try your above later on and post back, when I look go to "go" then "computer" I see a120 GB HD label OS_TOOLS and file system. Looked thru both but cant find "MY pictures" or "My documents" like it has in the link to copy. There is some folders there but nothing in them.
 
#6
used mini tool to make the 103 GB a NTFS and active partition, tried to boot it up but screen says "missing operating system"

I see the 7 GB backup but I am unable to copy it. Am I suppose to be able to burn it to a CD? If I do a restore will this be protected and I can do some sort of back up after the restore process?

Also I have a USB jump drive that I keep some pictures and music on, how can see it to see if there is a good back up on it? if there is I guess I will just do a system restore from the Windows recovery essentials.