Installed EasyBCD in Win10 Tried to add Win7

#1
I have a new PC with Win 10 installed. I installed EasyBCD 2.3.0.207. When I start EasyBCD it says it's booting in EFI mode. In Security, Secure Boot, I disabled Secure Boot and Secure RollBack Prevention. In Startup, I changed UEIF/Legacy Boot from UEIF Only to Both, Legacy First.
Does that mean that as long as EasyBCD is installed in Win10 it must be in EFI mode?
When I use EasyBCD booted from Win7 on the old PC it doesn't say it's in EFI mode.

When I try to boot into Win7 on the new PC I get a black screen saying:
Windows failed to start
File: \Windows\System32\winload.efi
Status: 0xc000000f

There are a total of 2 entries listed in the bootloader.
Default: Not set
Timeout: 4 seconds
EasyBCD Boot Device: C:\
Entry #1
Name: Windows 10
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.efi

Entry #2
Name: Windows 7
BCD ID: {035d16ef-7481-11e5-9bc6-54ee75758af4}
Drive: D:\
Bootloader Path: \Windows\system32\winload.efi


This is a GPT drive.

Thanks,
Docfxit
 

Attachments

mqudsi

Mostly Harmless
Staff member
#2
Once Windows is installed as EFI, drastic measures must be taken for it to actually boot in non-UEFI mode.
If you have a copy of EasyRE, running the automatic repair automatically creates a multi-boot environment where both the UEFI and legacy bootloaders are enabled simultaneously letting you do exactly what you're trying to do, but I wouldn't recommend doing that unless you have a good reason.

You did configure your PC to boot legacy OSes before trying UEFI, but since Windows isn't configured as MBR-boot, simply flipping a switch in the BIOS will do nothing.