installing/running EASYBCD beta 2 rel 64 on Win7 64

ebax

New Member
#1
EASYBCD beta 2 r 64 installs in (x86) prog files on my Win7 rtm x64 install, but when executed (as admin) it does not bring up the GUI, but both BCDEDIT & EASYBCD show in the task mgr. I discovered this when I tried to uninstall it and it said pgm was executing!! I was hoping to try the boot from VHD option.
 
#2
It is supposed to install in Program Files (x86).

Do you mean you rt click and run as admin on EasyBcd.exe and the GUI doesn't appear?

Strange - it does for me.

I put a shortcut on the desktop and run it from there, usually.
 

mqudsi

Mostly Harmless
Staff member
#3
EasyBCD shouldn't require you to manually run as Administrator.... It should elevate by itself. Does it not, SIW2?

I'm using it on Windows 7 x64 myself.
 
#4
Hi CG,

Yes it elevates itself just fine.

It also runs fine when run as admin - because that is what ebax was doing , when strangely, the GUI did not appear for him:

but when executed (as admin) it does not bring up the GUI
 
Last edited:

JustinW

Super Moderator
Staff member
#5
You got UAC enabled there ebax? If not go ahead and enable it and don't run as admin manually (let EasyBCD auto-elevate).
 

mqudsi

Mostly Harmless
Staff member
#6
EasyBCD should run fine regardless of whether UAC is on and elevation is then requested, or UAC is off and it is used normally.
 
A

asadaf

Guest
#7
I've got UAC fully disabled. Was running 1.7.2 fine until somewhere I saw Guru mentioning that grub's syntax had changed. So I grabbed the 64th Beta build of 2.0 and it installed over 1.7.2 and indeed it did run for a short period of time.

The GUI worked fine at first... up until I decided to add a bunch of linux/grub records, selecting various disks and partitions in a sort-of rapid-fire session of record creation. I was testing a bunch of different methods to get Grub working. I didn't realize I had to choose the disk itself, not the partition where grub is physically located (at least the menu.lst file).

Now the GUI is stuck hidden somewhere and I can only bring it up after killing bcdedit.exe... but that only lasts so long. Eventually bcdedit relaunches and then freezes the GUI window again.

Fortunately, despite the crash and no-show GUI, the records seem to have been written to the MBR, which is how I found that using just the disk where grub was installed, not a specific partition, worked fine, even though the menu.lst is located on a specific partition.

I did experience a freeze on the GUI in 1.7.2 ...just not any vanishing acts like the beta has been tossing at me.

I've now reinstalled several times, and it seems it makes no difference. Is there a cleaner install than the standard method?
Otherwise maybe the BCD being read in is causing issues?

Anyway, the MBR now has about 5 erroneous grub-related entries that I need to clean up, I just can't any longer.


Addendum:


By the way, this is on a fresh install of win7.

I just enabled UAC once again. I set it on level one, then rebooted as prompted.

I restarted Diffic ..er, EasyBCD 2, and I did get the usual UAC prompt: "do you want to allow this program from an unknown publisher to make changes to your computer?"

After that, it was the same old shindig. No GUI, both process still running though.

I can only imagine it has issues with my now-crazy MBR entry-set. Since I can't edit it now, there's no seeming way to fix it either. Killing bcdedit at least brings up the GUI and lets me copy the overview (pressing any buttons relaunches bcdedit though, which as I said re-freezes the GUI window).

Sorry if this is ugly, but setting up linux really isn't intuitive at all. If grub only supports selection of the disk, why list the partitions?

Anyway, I digress. Here's the overview:

There are a total of 9 entries listed in the bootloader.
Default: Windows 7
Timeout: 30 seconds.
EasyBCD Boot Device: D:\
Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #2
Name: Windows Vista
BCD ID: {04eac9f9-b416-11de-839c-fef433ef97f9}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe
Entry #3
Name: Ubuntu 9.10
BCD ID: {04eac9fa-b416-11de-839c-fef433ef97f9}
Drive: C:\
Bootloader Path: \NST\nst_grub.mbr
Entry #4
Name: Ubuntu (via Grub)
BCD ID: {04eac9fb-b416-11de-839c-fef433ef97f9}
Device: \Device\HarddiskVolume1
Bootloader Path: \NST\NeoGrub.mbr
Entry #5
Name: Linux (Grub)
BCD ID: {04eac9fc-b416-11de-839c-fef433ef97f9}
Drive: D:\
Bootloader Path: \NST\nst_linux.mbr
Entry #6
Name: Linux (Grub C)
BCD ID: {04eac9fd-b416-11de-839c-fef433ef97f9}
Drive: D:\
Bootloader Path: \NST\nst_linux-7DA69BABF255895CBEF0228AE982D44F.mbr
Entry #7
Name: Linux (Grub D1)
BCD ID: {04eac9fe-b416-11de-839c-fef433ef97f9}
Drive: D:\
Bootloader Path: \NST\nst_linux-6BB95DC1C44A86688FA4CFC1A1E619F0.mbr
Entry #8
Name: Linux (Grub D1S1)
BCD ID: {04eac9ff-b416-11de-839c-fef433ef97f9}
Drive: D:\
Bootloader Path: \NST\nst_linux-AF09B58298AABD4CCD5ACD977EB4DE37.mbr
Entry #9
Name: Unnamed Entry
BCD ID: {04eaca00-b416-11de-839c-fef433ef97f9}
Drive: D:\
Bootloader Path: \NST\nst_linux-B3E37EB2F761307A5487B922D506D143.mbr

Addendum:


Also, something strange happened after installing the beta (vs what v1.7.2 did) which was installing the NST settings on the D:\ drive. Version 1 installed NST settings into C:\.

I also have no idea why this shows C:\ for both vista and win7 ...vista should be on D:\

Entry #7 is the one that works for Grub, in case you wondered...
 
Last edited by a moderator:

Terry60

Knows where his towel is.
Staff member
#8
Hi asadaf, welcome to NST.
I don't quite understand what you've done from your description (NTLDR ? - thats XP ! and EasyBCD writes nothing to the MBR unless you use "uninstall/reinstall Vista bootloader" facilities, which I trust you haven't been doing just on a whim.)
Whatever it is, if (Microsoft's) BCDedit is hanging and needing to be removed by force, you would appear to have corrupted the BCD in some way.
Since you don't have the ability to run EasyBCD to recreate it, boot your W7 DVD, run "repair your computer" / "startup repair" as many times as necessary to get W7 booting cleanly with a fresh BCD, and add your Linux entry(s) again.
Select the Linux partition from the dropdown menu, and tick "grub isn't......" if Linux is not on the same HDD as W7. (Don't tick if they share a HDD)
 
A

asadaf

Guest
#9
Furthermore, it looks like killing bcdedit.exe any time it is running allows me to progressively step through the bugginess and use the GUI window.

For example:

Launch
GUI hidden
kill bcdedit.exe
GUI appears

Click Detailed Overview (Debug Mode)
GUI freezes
kill bcdedit.exe
Detailed Overview appears

Click Add/Remove Entries
GUI Freezes
kill bcdedit.exe
Add/Remove section shows, entries list blank
kill bcdedit.exe
Entries show

Click Entry to Delete
Click Delete Button
kill bcdedit.exe
Entries Blank
kill bcdedit.exe twice
Entries show, minus the deleted record

Also there was an error that popped up but I was too quick to dismiss it.

Plus, at some point I killed bcdedit.exe so many times that it allowed me to delete the rest of my unnecessary entries without freezing or relaunching bcdedit.exe

Addendum:

NTLDR ? - thats XP ! and EasyBCD writes nothing to the MBR unless you use "uninstall/reinstall Vista bootloader" facilities, which I trust you haven't been doing just on a whim.)
Terry, I probably have my vocab a bit mixed up. I've been calling MBR => NTLDR ...probably because at some point I removed (yes, on a whim) the vista MBR (even though I don't have XP installed) ...which prompted the computer to display the 'Missing NTLDR' message.

And yes, to fix that little mishap, I did have to locate a Vista disk and repair startup (twice).

After that, I could get back into win7, but not vista. But apparently that's because I patched tcpip and forgot to allow unsigned drivers in the Advanced Options section of EasyBCD.

Fun times. :grinning:

Addendum:

EasyBCD seems to be running fine now. Maybe I just needed to remove some buggy entry somewhere (via the "kill bcdedit.exe" hack/workaround I mentioned).
 
Last edited by a moderator:

Terry60

Knows where his towel is.
Staff member
#10
Our posts are crossing, so I now see your BCD addendum.
You have W7 and Vista both on C !!
You must point longhorn entries in the BCD at the partition containing the OS. That will have a letter other than C.
The BCD doesn't actually contain letters, it uses partition UIDs, but easyBCD translates them into letters (as seen by the system that you're running it on) for your convenience. The Vista and W7 systems cannot both be on C (as seen by either of them) even if they both see themselves as C when they're running.
The BCD entry for Vista as seen by W7 should reflect the partition letter that Vista has when you look at it in Explorer from W7.
 
A

asadaf

Guest
#11
Actually I don't, vista is on a separate drive than win7.

I have four HDDs: vista, win7, ubuntu and an empty drive.

Vista being assigned to disk C:\ by EasyBCD was a bug somewhere down the line. (Probably from v1.7.2 which I noticed stored vista as C:\ even though I told it D:\ ...it did it every time I tried. I had to go back and edit it after adding. )

Until yesterday, vista was always on C:\ and the drive that now holds win7 was a storage drive E:\

Now win7 is C:\ and vista is D:\ (at least when booting into win7).

Addendum:

Whatever it is, if (Microsoft's) BCDedit is hanging and needing to be removed by force, you would appear to have corrupted the BCD in some way.

Also, whether or not my MBR was corrupted, it still worked fine during bootup. It just wasn't working in EasyBCD.

Addendum:

And finally, just for fun I tried your suggestion for Grub, and indeed it does not work:

Select the Linux partition from the dropdown menu, and tick "grub isn't......" if Linux is not on the same HDD as W7. (Don't tick if they share a HDD)

My method for loading Grub still holds true:

Choose the disk that holds the partition where Grub is installed, but don't choose that partition itself. Then keep "Grub isn't installed to MBR/Bootsector" unchecked.

Perhaps my interpretation of that is off, in which case refinement may be needed, but I since on that chosen disk, which holds my various Ubuntu installs, I assume Grub is installed to the bootsector, since I can change the boot disk to that disk in my partition editor, and Grub starts instead of windows boot screen. Kinda makes sense though, since the Ubuntu install process is what put Grub on there in the first place. It didn't put it on either of the windows drives.
 
Last edited by a moderator:
#12
That's interseting Easybcd 2.0 crashed on me too . That was when I had 2 ntldr entries pointing at the same drive.

Trying to open Easybcd from the shortcut several times resulted in several instances of bcdedit.exe running in task manager - but no Easybcd GUI.

Cleaning up the bcdedit entries manually, then reinstalling Easybcd did the trick for me.
 

mqudsi

Mostly Harmless
Staff member
#13
Yuck... looks like the new bcdedit from Windows 7 is a little buggy, eh?
 

mqudsi

Mostly Harmless
Staff member
#16
I'd appreciate if anyone experiencing these hangs could send me a copy of the BCD configuration, so I can get in touch with my contacts on the Windows development team and have them check out this bcdedit behavior.

Two ways:
1) EasyBCD | Backup and Restore | Backup
2) bcdedit.exe /export C:\path\to\file

Thanks.
 
#17
Hi Mahmoud ,

Previously I had duplicate entries for ntldr. Clicking Easybcd - it didn't open. Click it again - still not. Click it third time - still not. Open Task Manager - 3 instances of bcdedit.exe running ( not surprising).

Killed those bcdedit.exe - still no joy - I had to reinstall Easybcd to get it working. Unfortunately, I didn't make a copy of bcd that time.

Tried to replicate it.

This time - created duplicate entry for winload entry. Easybcd opened fine. Froze when trying to view Debug mode. Kill Easybcd in Task Manger. Open it again - still OK - except trying to view in Debug mode - Easybcd froze again.

View attachment EXTRA_WINLOAD_ENTRY.txt

View attachment easybcd_2.zip


Third attempt. Removed Extra winload entry. Created extra ntldr entry. Exactly the same. Easybcd opens fine , but freezes while attempting to view in debug mode.

View attachment EXTRA_NTLDR_ENTRY(XP2).txt

View attachment easybcd_2 (2).zip

Bcdedit.exe itself seems to work fine via command prompt.
 
Last edited: