Laptop won't POST after EasyBCD modification

Kant

New Member
#1
I used EasyBCD to change the boot drive and to recreate the MBR ...

After I did that when I restarted my laptop it won't even make it to the BIOS screen. The laptop turns on, yes, and the fan spins SUPER loud, but I'll leave it there for hours and nothing happens. The laptop just sits at a black screen. The monitor doesn't even turn on.

I tried the following troubleshooting steps:

1) Remove battery and unplug computer to flush the CMOS. I actually left the computer like this overnight and after that I pushed the power button for a minute to drain the CMOS. I then tried turning the computer on again. No cigar.

2) Remove and reseat RAM. I tried every combination possible. I even tried booting the computer with no RAM. My previous experience with Dell computers is that they'll boot without any RAM at all but the computer will quickly tell you to install some RAM. I even cleaned the contacts of the RAM. So I don't think the RAM is at fault.

3) I tried the monitor diagnostics by booting the computer while holding the "D" key (if you have a Dell laptop, you can try this yourself. It's a common Dell troubleshooting step). I know my monitor is working, because my monitor started cycling through variously colored screens, from red to blue to black to white and so on. But the computer still won't reach the BIOS splash screen!

4) I removed everything that was plugged into the computer and tried to boot it. Still no cigar. I even removed the SSD I had in the CD/DVD bay. Didn't do squat.

So is it possible that my use of EasyBCD damaged my laptop to the point where it can't even boot up to the BIOS? Not knocking EasyBCD; it's great software and I've been using it for years without a problem. From what I understand, EasyBCD shouldn't be able to corrupt a BIOS. Has anyone else had this issue? Any troubleshooting tips remaining?
 
Last edited: