Linux partition suddenly became unreachable

#1
Hello everyone

Last time I tried booting into linuxmint 13 I suddenly got into a grub4dos screen. Not sure about what to do I tried the quit cmd and grub4dos returns error 39: Grub not booted from dos, or backupcopy at physical address 0x200000 corrupt. The only cmd I was sure enough of using was the reboot cmd. So luckily I can still boot into windows 7.

The installation seemed to work as it should for like 2 or 3 weeks. I installed it with the default partitions, made by the installer itself (which I read afterwards is not the best idea). I added the bootscreen with EasyBCD and seemed to work perfectly, until now :frowning:

Since I'm a beginner in dual booting os'es I really don't know what is going on and how to restore this and get linux mint to boot again? It looks like my linux partition is permanently lost. I hope someone can identify this problem and get me going again.

thanks for reading
 

Mak 2.0

Mod...WAFFLES!?!?
Staff member
#2
Have you looked at the Disk Management screen to make sure that the partition is truly gone? Have you made changes to the system? What have you done to try and diagnose the problem to confirm your suspicion that the drive is "gone"?
 
#3
Hello Mak 2.0

I didn't make any major changes to the system after this problem occured, perhaps the only thing I tried was a BCD bootfile repair. But it didn't solve the problem. At which point I became clueless what to do next. If I look at the diskmanager it says that the partition with linux on is on 100% capacity? Like there is totally no data present. I included a print screen of the disk manager.

screenshot_diskman.png

I know for sure that I did not deliberately format the partition or deleted any important files. I assume that something went wrong in the background ( I wouldn't be surprised, since I'm a beginner with linux :smile:. If someone can assist in verifying that the partition and my data is gone? Or perhaps to restore the problem, in case not all is lost.

If it helps, here is the bootmenu setup I have going on right now:

There are a total of 2 entries listed in the bootloader.

Default: Windows 7
Timeout: 30 seconds
EasyBCD Boot Device: C:\

Entry #1
Name: Windows 7
BCD ID: {current}
Drive: C:\
Bootloader Path: \Windows\system32\winload.exe

Entry #2
Name: Linux Mint 13
BCD ID: {a42031d0-11e3-11e0-8b7b-cfadb754dc7b}
Drive: C:\
Bootloader Path: \NST\AutoNeoGrub0.mbr


thanks for reading :wink:
 
Last edited:

Terry60

Knows where his towel is.
Staff member
#4
Disk Management does not acknowledge the existence of Linux partition file systems. Indeed, as you can see, it even gets confused about primary/logical status when "foreign" file systems are involved. (There can only be a maximum of 4 partitions if all are primary)
There is a Windows app which can examine the contents of Linux partitions.
Get a copy here
Download ext2explore 2.2.71 Free - View your ext2 / ext3 files with this tool. - Softpedia
and it should tell you if your data is intact
 

mqudsi

Mostly Harmless
Staff member
#5
Or in EasyBCD's partition list.
 
#6
@Terry60:
Thanks for the tool. It opened the linux partition easily. So far I backed up all the crucial data. It wasn't that much fortunately.

Is there by any chance a solution to the problem of why I'm presented the Grub4Dos command screen? Or shouldn't I need to bother and just reinstall the os instead?
 

Terry60

Knows where his towel is.
Staff member
#7
I would imagine someone with more Linux expertise could sort out the grub problem and get you back into Mint, but that's not me I'm afraid.
My response when Ubuntu was the only one of my four (at that time) OSs that refused to boot after I'd shuffled things around onto new bigger HDDs, was just to reinstall it, but I only ever used it as a test/play OS, so it never had anything of importance that I'd miss.
 
#8
No problem, I will wait a couple of days, when I have the liberty off tinkering with crucial stuff again, before I attempt some things myself. Hopefully someone recognizing the problem I described. I figure there will be much more to learn from it than just a clean reinstallation. Now I don't have any clue what I did wrong. ^^ And else, I can safely reinstall the os if need be. I didn't had much data to recover so it is no big deal.
 

mqudsi

Mostly Harmless
Staff member
#9
To boot LinuxMint with EasyBCD, it's as easy as using the latest beta: EasyBCD 2.2 Beta Builds

Just remove and re-add the entry with it.